Package Details: nncmpp-git v2.0.0.r11.gda83dbe-1

Git Clone URL: https://aur.archlinux.org/nncmpp-git.git (read-only, click to copy)
Package Base: nncmpp-git
Description: MPD client
Upstream URL: https://git.janouch.name/p/nncmpp
Licenses: custom:0BSD
Conflicts: nncmpp
Provides: nncmpp
Submitter: premysl
Maintainer: premysl
Last Packager: premysl
Votes: 1
Popularity: 0.000093
First Submitted: 2016-10-12 14:01 (UTC)
Last Updated: 2022-10-08 23:13 (UTC)

Latest Comments

premysl commented on 2022-08-23 20:35 (UTC)

m040601, that is asciidoctor. I've changed CMakeLists.txt so that you can replace asciidoctor with asciidoc in the PKGBUILD now.

m040601 commented on 2022-08-23 16:45 (UTC) (edited on 2022-08-23 16:50 (UTC) by m040601)

Thanks for providing this PKGBUILD. I had never heard about this mpd client, and was curious to test it as it says it works both on the terminal and x11.

But then,

[Repo Make:33]  rubygems-3.3.19-1  ruby-abbrev-0.1.0-1  ruby-base64-0.1.1-1  ruby-benchmark-0.2.0-1  ruby-bigdecimal-3.1.2-1  ruby-bundler-2.3.19-1  ruby-cgi-0.3.2-1  ruby-csv-3.2.3-1  ruby-date-3.2.2-1  ruby-delegate-0.2.0-1  ruby-did_you_mean-1.6.1-1  ruby-digest-3.1.0-1  ruby-ruby2_keywords-0.0.5-1  ruby-drb-2.1.0-1  ruby-reline-0.3.1-1  ruby-irb-1.4.1-1  ruby-json-2.6.2-1  ruby-uri-0.11.0-2  ruby-net-http-0.2.2-1  ruby-stringio-3.0.2-1  ruby-time-0.2.0-2  ruby-open-uri-0.2.0-2  ruby-psych-4.0.4-2  ruby-rdoc-6.4.0-2  ruby-stdlib-3.0.4-7  ruby-minitest-5.16.3-1  ruby-power_assert-2.0.1-1  ruby-rake-13.0.6-1  ruby-rexml-3.2.5-1  ruby-test-unit-3.5.3-1  ruby-bundledgems-3.0.4-7  ruby-3.0.4-7  asciidoctor-2.0.17-1
[Aur:1]  nncmpp-git-v1.2.0.r5.g830a744-1
:: Remove make dependencies after install? [y/N] ^C

So I stopped. I'm not gonna install ruby and rubygems just because of this PKGBUILD. Even if they are just a make dependency that can be removed later. I like my systems simple and clean.

I then checked the nncmpp website,

Build dependencies: CMake, pkg-config, asciidoctor, liberty (included), termo (included)
Runtime dependencies: ncursesw, libunistring, cURL
Optional runtime dependencies: fftw3, libpulse, x11, xft

And see no mention of ruby there.

Is the reason you introduce that dependency on your PKGBUILD absoluteley necessary ? Or could it be simplified ?

Thanks in advance.

joshpetit commented on 2021-05-04 22:57 (UTC)

I got this error while installing:

warning: dependency cycle detected:
warning: ruby will be installed before its rubygems dependency
warning: dependency cycle detected:
warning: ruby-irb will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-reline will be installed before its ruby dependency

It all installed fine however.