Package Details: octopi 0.8.5-2

Git Clone URL: https://aur.archlinux.org/octopi.git (read-only)
Package Base: octopi
Description: A powerful Pacman frontend using Qt5 libs
Upstream URL: http://octopiproject.wordpress.com
Licenses: GPL2
Conflicts: octopi-git
Submitter: ImNtReal
Maintainer: ImNtReal
Last Packager: ImNtReal
Votes: 233
Popularity: 4.266523
First Submitted: 2013-09-03 23:42
Last Updated: 2016-11-02 17:54

Dependencies (19)

Required by (1)

Sources (2)

Pinned Comments

ImNtReal commented on 2017-02-08 19:06

Please, do not use yaourt to install this package. It does not handle conflicts inside of a split package correctly. This can be installed by building manually, or by using pacaur, and specifying one of the octopi-notifier- packages.

Latest Comments

kingcreole commented on 2017-04-06 15:00

oh, i updated, and openssl 1.0 installed/upgraded now everything works fine again :)

kingcreole commented on 2017-04-06 14:56

thanks for the tip, rebuilding crashes with these warnings:

/usr/bin/ld: warning: libssl.so.1.0.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../../lib/libQt5Network.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libcrypto.so.1.0.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/6.3.1/../../../../lib/libQt5Network.so, not found (try using -rpath or -rpath-link)

and a lot of undefined reference errors :)

ImNtReal commented on 2017-04-05 12:50

@kingcreole, have you tried rebuilding since updating to openssl 1.1? I haven't tried building against it, yet.

kingcreole commented on 2017-04-05 11:47

Hey, i have the testing Packages active, wich gives me openssl 1.1, now i get this error:
octopi: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory
Is there something i can do about it or will this be fixed? a lot of my programs have this Issue since they need to move to 1.1
It's not a big issue if it's a lot of work, i can get arround using octopi for a bit, thank you for your great work :)

ImNtReal commented on 2017-02-08 19:06

Please, do not use yaourt to install this package. It does not handle conflicts inside of a split package correctly. This can be installed by building manually, or by using pacaur, and specifying one of the octopi-notifier- packages.

D4v2z commented on 2017-02-08 18:56

@adomas Install : https://aur.archlinux.org/packages/octopi-git/

adomas commented on 2017-02-08 00:00

I have this issue which @Aeronaelius mentioned. Using yaourt fails to install:
==> Continue installing octopi ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==> y

loading packages...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: octopi-notifier-frameworks and octopi-notifier-qt5 are in conflict
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-adomas

Aeronaelius commented on 2017-01-18 11:44

@ImNtReal
Building manually gives the same error. There is a conflict in the PKGBUILD file of 'octopi':

pkgname=('octopi' 'octopi-pacmanhelper' 'octopi-notifier-qt5' 'octopi-notifier-frameworks' 'octopi-repoeditor' 'octopi-cachecleaner')

It builds both the 'octopi-notifier-qt5' and the 'octopi-notifier-frameworks' packages and those two are in conflict (look at their respective PKGBUILD files).

I successfully installed 'octopi' with yaourt by editing its PKGBUILD file and removing any mention of 'octopi-notifier-qt5'. This way it only builds 'octopi-notifier-frameworks'. The conflict error is no longer triggered.

I think it would be best if the PKGBUILD asks the user whether to install 'octopi-notifier-qt5' or 'octopi-notifier-frameworks'.

ImNtReal commented on 2016-11-26 22:27

@dracorp, yaourt won't work for installing this package. Please, build it manually, or use pacaur. Read previous comments for details on why.

dracorp commented on 2016-11-25 08:32

@ImNtReal
Clean installation of octopi:

yaourt -S octopi
(...)
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: octopi-notifier-frameworks and octopi-notifier-qt5 are in conflict

All comments