Package Details: openfx-io-git 2.3.11-3

Git Clone URL: https://aur.archlinux.org/openfx-io-git.git (read-only)
Package Base: openfx-io-git
Description: A set of Readers/Writers plugins written using the OpenFX standard
Upstream URL: https://github.com/MrKepzie/openfx-io
Licenses: GPL2
Submitter: bm456
Maintainer: bm456
Last Packager: bm456
Votes: 0
Popularity: 0.000000
First Submitted: 2017-11-03 02:58
Last Updated: 2018-05-01 02:50

Latest Comments

christianlupus commented on 2019-05-22 11:55

I get the problem that when I try to compile the package I get the following error:

../OIIO/ReadOIIO.cpp: In member function 'virtual void {anonymous}::ReadOIIOPluginFactory::load()':
../OIIO/ReadOIIO.cpp:2977:35: error: 'LIBRAW_CAPS_DEMOSAICSGPL2' was not declared in this scope
         bool libraw_gpl2 = caps & LIBRAW_CAPS_DEMOSAICSGPL2;
                                   ^~~~~~~~~~~~~~~~~~~~~~~~~
../OIIO/ReadOIIO.cpp:2977:35: note: suggested alternative: 'LIBRAW_CAPS_DNGSDK'
         bool libraw_gpl2 = caps & LIBRAW_CAPS_DEMOSAICSGPL2;
                                   ^~~~~~~~~~~~~~~~~~~~~~~~~
                                   LIBRAW_CAPS_DNGSDK
../OIIO/ReadOIIO.cpp:2978:35: error: 'LIBRAW_CAPS_DEMOSAICSGPL3' was not declared in this scope
         bool libraw_gpl3 = caps & LIBRAW_CAPS_DEMOSAICSGPL3;
                                   ^~~~~~~~~~~~~~~~~~~~~~~~~
../OIIO/ReadOIIO.cpp:2978:35: note: suggested alternative: 'LIBRAW_CAPS_DNGSDK'
         bool libraw_gpl3 = caps & LIBRAW_CAPS_DEMOSAICSGPL3;
                                   ^~~~~~~~~~~~~~~~~~~~~~~~~
                                   LIBRAW_CAPS_DNGSDK
../OIIO/ReadOIIO.cpp: In member function 'virtual void {anonymous}::ReadOIIOPluginFactory::describeInContext(OFX::ImageEffectDescriptor&, OFX::ContextEnum)':
../OIIO/ReadOIIO.cpp:3312:43: error: 'LIBRAW_CAPS_DEMOSAICSGPL2' was not declared in this scope
                 bool libraw_gpl2 = caps & LIBRAW_CAPS_DEMOSAICSGPL2;
                                           ^~~~~~~~~~~~~~~~~~~~~~~~~
../OIIO/ReadOIIO.cpp:3312:43: note: suggested alternative: 'LIBRAW_CAPS_DNGSDK'
                 bool libraw_gpl2 = caps & LIBRAW_CAPS_DEMOSAICSGPL2;
                                           ^~~~~~~~~~~~~~~~~~~~~~~~~
                                           LIBRAW_CAPS_DNGSDK
../OIIO/ReadOIIO.cpp:3313:43: error: 'LIBRAW_CAPS_DEMOSAICSGPL3' was not declared in this scope
                 bool libraw_gpl3 = caps & LIBRAW_CAPS_DEMOSAICSGPL3;
                                           ^~~~~~~~~~~~~~~~~~~~~~~~~
../OIIO/ReadOIIO.cpp:3313:43: note: suggested alternative: 'LIBRAW_CAPS_DNGSDK'
                 bool libraw_gpl3 = caps & LIBRAW_CAPS_DEMOSAICSGPL3;
                                           ^~~~~~~~~~~~~~~~~~~~~~~~~
                                           LIBRAW_CAPS_DNGSDK
make[1]: *** [../openfx/Support/Plugins/Makefile.master:83: Linux-64-release/ReadOIIO.o] Error 1
make[1]: Leaving directory '/home/christian/.cache/aurutils/sync/openfx-io-git/src/openfx-io/IO'
make: *** [Makefile:22: IO] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

Can you tell me what is the problem here and what I need to do in order to get things running again?

tecnotercio commented on 2017-12-08 13:58

As of version 2.3.4, the openfx-io package uses the latest version of the seexpr library (2.11).

https://github.com/MrKepzie/Natron/blob/master/CHANGELOG.md

Replace "seexpr1" package by "seexpr" in the PKGBUILD.

oberon2007 commented on 2017-11-28 23:59

Please add provides=('openfx-io') !