Package Details: openra-git BLEED.20200921.9cf38c1784-1

Git Clone URL: https://aur.archlinux.org/openra-git.git (read-only, click to copy)
Package Base: openra-git
Description: An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL. -GIT VERSION
Upstream URL: http://www.openra.net
Licenses: GPL3
Conflicts: openra
Provides: openra
Submitter: EndlessEden
Maintainer: EndlessEden
Last Packager: EndlessEden
Votes: 5
Popularity: 0.000000
First Submitted: 2015-12-24 06:08
Last Updated: 2020-09-21 09:04

Pinned Comments

EndlessEden commented on 2017-08-16 00:13

Updated: Fixed the removal of "make dependencies" upstream;

will be removing old entries for RA2/D2 soon, as building against upstream is not possible as RA2/D2 are lagging behind too much in updating their engine compatibility.

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

EndlessEden commented on 2018-04-12 06:11

@Enverex - I did plan to remove them, i just haven't had time. Anyone can feel free to send me patches and suggestions. I will try to incorporate them were they feel right.

@mailme45 - From the openra client - openra -mod ra2 (or -mod RA2 [im not sure, as its been 6+months])

@promoke - Sorry, its not easy to balance logging and work. Alot of my updates dont get proper notes, as i forget what ive done in my haste. - As far as RA2, i Did test it, it does launch, etc. but i was unable to test it very thoroughly. It can be launched via -mod RA2

<hr>

I will do what i can to add a launcher, etc for RA2/etc asap.

Enverex commented on 2018-04-10 14:34

Is it worth disabling the tests at build time? It causes it to take a very long time to build and isn't really anything users need, it's more for the devs.

mailme45 commented on 2018-04-08 19:03

@EndlessEden how do I launch ra2?

promike commented on 2017-12-13 14:43

@EndlessEden No, you're missing the point. I didn't put you down because you hadn't maintained the package around the clock, but I did expect some response when I struggled to start RA2. No-one told me it's full of bugs and won't work. All I could see was the package description: ...DuneII and Red Alert 2, mods Included, and your commit message: 2017-09-09 Fixed RA2 so that its functioning. Had I known these, I wouldn't have pestered you. I'm actually grateful to you trying maintaining this package, however, you could be more verbose next time!

EndlessEden commented on 2017-12-12 13:41

@promike: I have a life outside package Maintenance. I didnt get a notification of a issue. ill look into it. (Also, her ^_^)

@Enverex: Ive been working on a launch-script. I just havent pushed it to Aur as its mono3-dependant.

@promike(22-10-2017): Ive been looking into the issue, and while it will launch, keep in mind. IT IS UNDER DEVELOPMENT. the most i could get was a buggy menu, and i havent debugged the issue. Please be Patient. OpenRA is not my only project.

promike commented on 2017-12-11 14:04

@Enverex

It's no use writing him... he won't reply or do anything. I've been struggling with openra-git for several months now. I don't feel like playing it anymore. We'd be better off installing the original RA2...

Enverex commented on 2017-12-07 09:26

You've added Dune 2 and RA2, but not scripts to launch them (e.g. openra-ra2). Any chance of adding those in? (Edit: Just realised these are created by the build process and not something you've added yourself. Any chance of creating them manually during the package process as a crutch until the build process makes these automatically?)

Also, was there any reason why you left out Tiberian Sun? As far as I'm aware it's further along than Red Alert 2 so including it seems like a good idea unless there's some big reason not to?

promike commented on 2017-10-22 19:06

Thank you for updating it. It finally installs. :)
Could you give me a hand installing Red Alert 2? I followed the instructions there: https://github.com/OpenRA/ra2/wiki

I placed

ra2.mix 09e1ef0582fa2dad39c0ae92d9ffda15 (md5sum)
language.mix 00dc102e9afe53cbad5ac1d4c5960b30 (md5sum)
theme.mix bc1faedbce43c393e9df0b784d6f2fba (md5sum)

into ~/.openra/Content/ra2/ but it keeps telling me 'Game Content Not Found'

p.s. I didn't alter you PKGBUILD, I installed it as it is

promike commented on 2017-09-20 11:39

Unfortunately, it cannot be installed:

Checking for code style violations in OpenRA.Server...
No violations encountered in OpenRA.Server.
patching file mod.config
Hunk #1 FAILED at 4.
1 out of 1 hunk FAILED -- saving rejects to file mod.config.rej
==> ERROR: A failure occurred in build().
Aborting...

EndlessEden commented on 2017-08-16 00:13

Updated: Fixed the removal of "make dependencies" upstream;

will be removing old entries for RA2/D2 soon, as building against upstream is not possible as RA2/D2 are lagging behind too much in updating their engine compatibility.