Package Details: osu-lazer 2022.911.0-1

Git Clone URL: https://aur.archlinux.org/osu-lazer.git (read-only, click to copy)
Package Base: osu-lazer
Description: The new open source version of osu!, the free-to-win rhythm game
Upstream URL: https://osu.ppy.sh/
Keywords: game lazer osu peppy ppy rhythm
Licenses: MIT, custom:CC-BY-NC 4.0
Submitter: morguldir
Maintainer: morguldir (ppy)
Last Packager: morguldir
Votes: 55
Popularity: 1.84
First Submitted: 2018-06-21 12:34 (UTC)
Last Updated: 2022-09-13 20:08 (UTC)

Latest Comments

1 2 3 4 5 6 .. 8 Next › Last »

Twikzer commented on 2022-08-22 15:47 (UTC)

when its gonna ben updated?

morguldir commented on 2022-06-08 19:23 (UTC)

What do you mean? This package doesn't auto update. But yes i use nvchecker, so there isn't much point in marking it out of date, but since it's a new person every time it's not really possible to stop it either.

bryiewes commented on 2022-06-08 18:00 (UTC)

This package autoupdates. Flagging out-of-date might not be helpful.

Sarisan commented on 2022-05-24 21:19 (UTC)

You shouldn't update version from 2022.509.0 since wayland support is broken and X11 has issues with resolution

ZhangHua commented on 2022-02-17 04:51 (UTC) (edited on 2022-02-17 05:19 (UTC) by ZhangHua)

ppy has upgrade dotnet to target 6.0 since version 2022.216.0, please update PKGBUILD so we can play it, thank you. This patch should works:

diff --git a/PKGBUILD b/PKGBUILD
index 3577f55..c89fc46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
 # Contributor: "donaldtrump" [AUR]

 pkgname=osu-lazer
-pkgver=2021.1111.0
+pkgver=2022.216.0
 pkgrel=1

-dotnet_version=5.0
+dotnet_version=6.0

 pkgdesc="The new open source version of osu!, the free-to-win rhythm game"
 arch=('x86_64')
@@ -15,7 +15,7 @@ license=('MIT' 'custom:CC-BY-NC 4.0')
 url='https://osu.ppy.sh/'

 depends=(ffmpeg libgl sdl2 shared-mime-info "dotnet-runtime>=$dotnet_version.0")
-makedepends=(git "dotnet-sdk>=$dotnet_version.5.sdk202")
+makedepends=(git "dotnet-sdk>=$dotnet_version.0.sdk100")

 source=(
     "osu-lazer::git+https://github.com/ppy/osu.git#tag=$pkgver"

ZhangHua commented on 2022-01-07 11:33 (UTC)

I think you can set dotnet-runtime=5.0.13 in depends and dotnet-sdk=5.0.13.sdk404 in makedepends. Both packages can be found on AUR and they should be the latest version of dotnet 5. After doing so, we can continue using newest game before ppy upgrade dotnet to 6.0.

yoshi3 commented on 2021-12-18 18:18 (UTC) (edited on 2021-12-18 18:20 (UTC) by yoshi3)

"...framework 'Microsoft.NETCore.App', version '5.0.0' (x64) was not found..."

(Kernel 5.15.x, dotnet 6.0)

instead of "AUR":

git clone https://github.com/ppy/osu.git
cd osu
dotnet publish -c Release -r linux-x64 --self-contained osu.Desktop

The Folder osu/osu.Desktop/bin/Release/net5.0/linux-x64/ now contains "osu" to play

XeonBionic commented on 2021-12-11 14:59 (UTC)

It was not possible to find any compatible framework version The framework 'Microsoft.NETCore.App', version '5.0.0' (x64) was not found. - The following frameworks were found: 6.0.0 at [/usr/share/dotnet/shared/Microsoft.NETCore.App]

You can resolve the problem by installing the specified framework and/or SDK.

The specified framework can be found at: - https://aka.ms/dotnet-core-applaunch?framework=Microsoft.NETCore.App&framework_version=5.0.0&arch=x64&rid=endeavouros-x64 I keep getting this error. Shouldn't this framework version be a installed dependency from the first place?