Package Details: otter-browser-git 0.9.99.r149.g6d9a7f72b-1

Git Clone URL: https://aur.archlinux.org/otter-browser-git.git (read-only)
Package Base: otter-browser-git
Description: Browser aiming to recreate the best aspects of the classic Opera (12.x) UI using Qt5 - git checkout
Upstream URL: http://otter-browser.org/
Keywords: browser c-plus-plus cross-platform opera otter qt web webkit
Licenses: GPL3
Conflicts: otter-browser
Provides: otter-browser
Submitter: Barthalion
Maintainer: m4sk1n
Last Packager: m4sk1n
Votes: 29
Popularity: 0.001143
First Submitted: 2014-01-01 20:07
Last Updated: 2018-07-01 11:21

Dependencies (8)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

arzeth commented on 2014-12-27 13:43

Now it depends also on qt5-multimedia (build fails without it): https://github.com/Emdek/otter/commit/3d1295dac820662abf9997defe1588d1dc7b02c5

Lenny commented on 2014-11-17 22:59

it's just a package version, package is built from git HEAD

ersi-dnd commented on 2014-11-17 17:09

The non-git release is at 0.9.03 while this is at 0.9.01 :S

MikuroK commented on 2014-07-03 23:24

makedepends=('cmake')
makedepends=('git')

should be:

makedepends=('cmake' 'git')

right now the second line overwrites the first and only git is requested for installation.

boenki commented on 2014-06-03 21:00

@haagch: please file bugreports here if you can https://github.com/Emdek/otter/issues

haagch commented on 2014-06-03 19:31

Works, but I get a segfault when going to get.webgl.org

Program received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
(gdb) bt
#0 0x0000000000000000 in ?? ()
#1 0x00007ffff5b1e2f7 in ?? () from /usr/lib/libQt5WebKit.so.5
#2 0x00007ffff5af03d3 in ?? () from /usr/lib/libQt5WebKit.so.5
#3 0x00007ffff5b1d6d6 in ?? () from /usr/lib/libQt5WebKit.so.5
#4 0x00007ffff4f30263 in ?? () from /usr/lib/libQt5WebKit.so.5
#5 0x00007ffff4f3c534 in ?? () from /usr/lib/libQt5WebKit.so.5
#6 0x00007ffff4f3905b in ?? () from /usr/lib/libQt5WebKit.so.5
#7 0x00007ffff5158290 in ?? () from /usr/lib/libQt5WebKit.so.5
#8 0x00007fff9280f0e5 in ?? ()
#9 0xffff000000000002 in ?? ()
#10 0x00007ffff5d82c76 in ?? () from /usr/lib/libQt5WebKit.so.5
#11 0x0000000000000000 in ?? ()

qt5-webkit 5.3.0-3

Is this a problem of archlinux's qt webkit or general?

boenki commented on 2014-01-16 22:23

libxcb dependency is already satisfied by qt5-webkit. qt5-webkit→qt5-sensors→qt5-declarative→qt5-xmlpatterns→qt5-base→libxrender→libx11→libxcb

license does not need to be copied, because GPL3 is a common license found in /usr/share/licenses/common/GPL3/license.txt

and there's a desktop file now. Just add
install -Dm644 ../otter-browser.desktop $pkgdir/usr/share/applications/otter-browser.desktop
to the end of package ()

Grüße aus Bonn
STeffen

someoneelse123 commented on 2014-01-05 12:41

Ok, to summarize.

Error from my first post appears on fully upgraded system, with everything qt5-related on 5.2.0-3. To resolve problem, I had to uninstall qt4, what, of course, broke half of my system.

I could install qt4 and use all qt4 apps and otter, but only after otter was built and installed. There has to be some sort of build conflict between qt4, qt5 and otter alone.

someoneelse123 commented on 2014-01-05 12:34

Still, very same error after complete system upgrade, with QT on...

$ pacman -Q|grep qt5
qt5-base 5.2.0-3
qt5-declarative 5.2.0-3
qt5-location 5.2.0-3
qt5-sensors 5.2.0-3
qt5-webkit 5.2.0-3
qt5-xmlpatterns 5.2.0-3

someoneelse123 commented on 2014-01-04 19:30

eworm: I had upgraded everything qt-related, as I didn't had qt5 at all and package deps on it. I'll try to upgrade rest of system.