Package Details: package-query-git 1.9.r10.gb912c5b-2

Git Clone URL: https://aur.archlinux.org/package-query-git.git (read-only)
Package Base: package-query-git
Description: Query ALPM and AUR
Upstream URL: https://github.com/archlinuxfr/package-query
Licenses: GPL
Conflicts: package-query
Provides: package-query=1.9
Submitter: tuxce
Maintainer: archlinuxfr (Skunnyk, f2404)
Last Packager: f2404
Votes: 153
Popularity: 0.517427
First Submitted: 2010-03-15 13:14
Last Updated: 2018-06-05 02:16

Dependencies (3)

Required by (5)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Anonymous comment on 2013-04-05 07:47

I get

==> Starting build()...
+ aclocal -I m4 --install
sh: autom4te: command not found
aclocal: error: echo failed with exit status: 127
+ autoheader
./autogen.sh: line 4: autoheader: command not found
+ automake --foreign
sh: autoconf: command not found
automake: error: autoconf failed with exit status: 127
+ autoconf
./autogen.sh: line 6: autoconf: command not found
==> ERROR: A failure occurred in build().
Aborting...

Please add autoconf to the makedepends.

tuxce commented on 2013-04-03 12:17

@Det, thanks

Det commented on 2013-04-01 13:26

That kind of VCS handling is no longer required in pacman 4.1: https://projects.archlinux.org/pacman.git/tree/NEWS, https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines

Sample PKGBUILD: http://pastebin.com/EPdTGSLR

vodik commented on 2012-04-30 09:15

@lafka https://wiki.archlinux.org/index.php/AUR#Getting_started

"Install base-devel (pacman -S base-devel), because members of this group are not explicitly required by AUR packages which may not build without them (more info in this thread)."

lafka commented on 2012-04-24 10:18

base-devel should be added as dependency.

tuxce commented on 2012-02-03 07:08

It's fixed, try again.

Anonymous comment on 2012-02-03 00:18

Tried to build manually, didn't work. Help?

$ make
make all-recursive
make[1]: Entering directory `/tmp/package-query-git/package-query-build'
Making all in src
make[2]: Entering directory `/tmp/package-query-git/package-query-build/src'
gcc -DLOCALEDIR=\"/usr/share/locale\" -DCONFFILE=\"/etc/pacman.conf\" -DROOTDIR=\"/\" -DDBPATH=\"/var/lib/pacman/\" -DAUR_BASE_URL=\"http://aur.archlinux.org\" -DHAVE_CONFIG_H -DGIT_VERSION=\"1.0.1-2-gd992\" -I. -I.. -D_GNU_SOURCE -g -O2 -MT aur.o -MD -MP -MF .deps/aur.Tpo -c -o aur.o aur.c
aur.c: In function ‘aur_request’:
aur.c:486:49: error: request for member ‘data’ in something not a structure or union
make[2]: *** [aur.o] Error 1
make[2]: Leaving directory `/tmp/package-query-git/package-query-build/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/package-query-git/package-query-build'
make: *** [all] Error 2

benjarobin commented on 2012-01-21 11:58

Please update provides=('package-query=0.8') to '1.0'

Anonymous comment on 2012-01-12 21:27

Please change opt depends from pacman-color to pacman-color-testing

meijin commented on 2011-12-29 07:15

hi. i can't install package-query-git. after makepkg entring fakeroot and starting "package()" I'm getting:
==> Entering fakeroot environment...
==> Starting package()...
make: *** No rule to make target `עבודה/package-query-git/pkg'. Stop.
==> ERROR: A failure occurred in package().
Aborting...

anyone?
Assaf