Package Details: phatch 0.2.7.1-11

Git Clone URL: https://aur.archlinux.org/phatch.git (read-only, click to copy)
Package Base: phatch
Description: A simple to use cross-platform GUI Photo Batch Processor.
Upstream URL: http://photobatch.stani.be
Licenses: GPL
Provides: phatch=0.2.7.1
Submitter: Mymaud
Maintainer: None
Last Packager: blubbblubb
Votes: 105
Popularity: 0.103833
First Submitted: 2007-10-07 08:52
Last Updated: 2019-04-30 13:21

Dependencies (6)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

xuv commented on 2015-05-26 18:12

@TiborB: Don't know. Have no idea how much just a patch could solve the problems we have right now. As I read the comments, there seems to be quite some work to do to keep this app updated. Just patching it might just keep it alive for a couple of months. But then... Don't know. Thinking out loud. Of course, a full fork is a big deal. Maybe too much at this time.

TiborB commented on 2015-05-26 17:50

Are we talking about full-fledged fork? Own homepage, repository, bug tracking and so on? If it is the case, then it would take more then one person, of course :)

xuv commented on 2015-05-26 17:38

Don't know if I can be of any help. But I would love to have this package running again. Have so much macros with it that it hurts it's not running anymore. Do you plan to host the code somewhere to encourage collaboration?

TiborB commented on 2015-05-19 20:10

Few days ago I tried to contact developers - no response. I was even considering participation in the project. At least I could try :)

Luckily it still works on debian, so for some time I can use my other box for processing my photos.

anish commented on 2015-05-19 19:57

@TiborB sadly yes, there has been no upstream update in a while, as a consequence no update here either. I haven't had to recompile this in a while. I'll take a look, but the actual code is way behind upstream python packages at this point.

If you find a fix, I'd be happy to add it to the PKBUILD and give you attribution.

TiborB commented on 2015-05-19 19:52

Hi, I am getting error:

File "/usr/lib/python2.7/site-packages/phatch/core/api.py", line 780, in apply_actions_to_photo
photo.close()
AttributeError: 'NoneType' object has no attribute 'close'

'python2-pillow is in version 2.4.0-1.

It is pity that this application is abandoned...

albertmatyi commented on 2014-09-09 15:59

Edit PKGBBULD and modify 'python2-pillow' to 'python2-pillow=2.4.0', that should fix the

AttributeError: 'NoneType' object has no attribute 'mode'

Issue

theo974 commented on 2014-08-25 15:18

flag out of date is an error

theo974 commented on 2014-08-25 15:15

@tesfabpel To solve the problem you should downgrade python2-pillow to python-pillow-2.4.0-1. look at http://osdir.com/ml/general/2014-08/msg42190.html

theo974 commented on 2014-08-25 14:53

@tesfabpel same error for me