Package Details: pioneer-git 20240203.r3.gde4796fe0-1

Git Clone URL: https://aur.archlinux.org/pioneer-git.git (read-only, click to copy)
Package Base: pioneer-git
Description: A game of lonely space adventure
Upstream URL: https://github.com/pioneerspacesim/pioneer
Keywords: game sim space
Licenses: GPL3
Conflicts: pioneer, pioneer-bin
Provides: pioneer
Submitter: yitzi
Maintainer: impaktor
Last Packager: manolollr
Votes: 4
Popularity: 1.12
First Submitted: 2015-12-25 18:01 (UTC)
Last Updated: 2024-02-05 17:37 (UTC)

Latest Comments

1 2 Next › Last »

impaktor commented on 2024-05-14 08:29 (UTC)

@manolollr Hi! I'm pioneer's project lead, and I'd be happy to take over as maintainer if need be.

pirogronian commented on 2024-03-23 15:32 (UTC) (edited on 2024-03-23 16:06 (UTC) by pirogronian)

I have found in recent changes around fmt library, in the contrib/fmt/CMakeLists.txt file, following change: option(FMT_INSTALL "Generate the install target." ${MASTER_PROJECT}) into option(FMT_INSTALL "Generate the install target." ON) Just testing modified PKBUILD with setting this OFF.

Edit: It works for me.

manolollr commented on 2024-03-17 18:28 (UTC) (edited on 2024-03-17 18:31 (UTC) by manolollr)

I'm going to disown this package. Now I have different priorities in my life and I haven't time to maintain it adequately.

The game is alive, with constant an interesting updates. Anybody who wishes to maintain this package is welcome.

Thank you.

manolollr commented on 2024-03-17 18:24 (UTC)

It seems the game now uses its own FMT library, and conflicts if you have already the package FMT installed.

I've tried to compile the game with the option -D FMT_SYSTEM_HEADERS:BOOL=ON but it doesn't work.

Unfortunately I don't know how to compile the game to avoid conflict with this package. Sorry.

Can you try to uninstall 'fmt' package? Is it needed by any software you have installed?

DaarkWel commented on 2024-03-15 15:52 (UTC)

Build ok but on install getting conflicting files error:

pioneer-git: /usr/include/fmt/args.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/chrono.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/color.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/compile.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/core.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/format-inl.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/format.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/os.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/ostream.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/printf.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/ranges.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/std.h exists in filesystem (owned by fmt)
pioneer-git: /usr/include/fmt/xchar.h exists in filesystem (owned by fmt)
pioneer-git: /usr/lib/cmake/fmt/fmt-config-version.cmake exists in filesystem (owned by fmt)
pioneer-git: /usr/lib/cmake/fmt/fmt-config.cmake exists in filesystem (owned by fmt)
pioneer-git: /usr/lib/cmake/fmt/fmt-targets.cmake exists in filesystem (owned by fmt)
pioneer-git: /usr/lib/pkgconfig/fmt.pc exists in filesystem (owned by fmt)

manolollr commented on 2023-11-27 18:36 (UTC)

Ok, now PKGBUILD is updated.

Thanks for testing, it's working again! It's adapted to new data directory.

The -D PIONEER_DATA_DIR:PATH=/usr/share/pioneer/data/ line is not needed for a fresh install but it's needed if the game is already installed, so at line 29 it's not included but it's included at line 43 and 44.

pirogronian commented on 2023-11-26 16:20 (UTC) (edited on 2023-11-27 16:11 (UTC) by pirogronian)

After installation I get a crash on startup, with error messagebox about missing shader.

The game seems to look for its files with wrong path:

/usr/share/pioneer/<path suffix> instead of /usr/share/pioneer/data/<path suffix>

I raised [an issue at github] (https://github.com/pioneerspacesim/pioneer/issues/5667) but they have concluded it's a PKBUILD issue:

The PKGBUILD script should be updated to either pass -DPIONEER_DATA_DIR:PATH=/usr/share/pioneer/data or omit the PIONEER_DATA_DIR argument entirely (it will be set from the CMake installation prefix anyways).

Edit: I edited PKBUILD with the second way (link), but the error have persisted.

Edit 2: I edited it again, this time with the first suggestion (link). This time game works correctly.

manolollr commented on 2023-02-08 11:30 (UTC)

Thank You!!! It works perfect. It's much better way.

ElonSatoshi commented on 2023-02-07 22:04 (UTC)

Instead of asking users to edit their /etc/makepkg.conf, can you add this line to the start of the build function?

CXXFLAGS="${CXXFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS/}"

manolollr commented on 2019-05-10 17:18 (UTC)

I'm not an expert in compiling. I've adopted the package because it was orphan for a long time and noboy haven't adopted it. There are workarounds not very elegant, but at least they work. We need collaboration of upstream game developers to fix this bugs, but it's difficult to me to write in English. Can someone help? If someone have more experience in compiling, I will disown this package and let him/her. Thanks!