Package Details: plasma-wallpaper-himawari-git r7.2049a94-1

Git Clone URL: https://aur.archlinux.org/plasma-wallpaper-himawari-git.git (read-only)
Package Base: plasma-wallpaper-himawari-git
Description: Plasma Wallpaper Himawari
Upstream URL: https://github.com/Hyperz/plasmahimawari
Licenses: GPL
Conflicts: plasma-wallpaper-himawari
Provides: plasma-wallpaper-himawari
Submitter: habarnam
Maintainer: wget
Last Packager: habarnam
Votes: 1
Popularity: 0.000000
First Submitted: 2016-02-05 12:06
Last Updated: 2016-10-14 10:42

Latest Comments

Ekaradon commented on 2016-10-14 12:54

Done, thank you.

habarnam commented on 2016-10-14 12:19

There is no animation.

The wallpaper changes the background image once every 15 minutes (I think) and I don't know if the screenlocker works the same way.

You can mention it on github, maybe the developer is interested in adding this functionality.

Ekaradon commented on 2016-10-14 11:39

Hello,

Thanks, it works now. However, even if this animation works for the desktop wallpaper, it does not work with the screenlocker while it should:
https://blog.martin-graesslin.com/blog/2016/07/animations-on-lock-screen-plasma-wallpaper-support/

Do you have any idea why? Should I put this as issue here:
https://github.com/Hyperz/plasmahimawari
?

habarnam commented on 2016-10-14 10:43

Hi Ekradon, thank you for the feedback.

The problem comes from a missing build dependency on cmake-modules-extra.

I have updated the PKGBUILD to reflect it, please try again.

The problem with $srcdir, I don't think it's a problem.

Ekaradon commented on 2016-10-14 10:24

I can confirm that adding the dependency `extra-cmake-modules` solves the issue.

I have however noticed a warning while building the package:

`==> WARNING: Package contains reference to $srcdir`

Ekaradon commented on 2016-10-14 09:20

Hello,

I was tring to use your package but I got an error while building:

```
==> Making package: plasma-wallpaper-himawari-git r7.2049a94-1 (Fri Oct 14 11:16:28 CEST 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning plasma-wallpaper-himawari git repo...
Cloning into bare repository '/home/ekaradon/aur/plasma-wallpaper-himawari-git/plasma-wallpaper-himawari'...
remote: Counting objects: 35, done.
remote: Total 35 (delta 0), reused 0 (delta 0), pack-reused 35
Unpacking objects: 100% (35/35), done.
==> Validating source files with md5sums...
plasma-wallpaper-himawari ... Skipped
==> Extracting sources...
-> Creating working copy of plasmahimawari git repo...
Cloning into 'plasma-wallpaper-himawari'...
done.
==> Starting pkgver()...
==> Starting build()...
-- The C compiler identification is GNU 6.2.1
-- The CXX compiler identification is GNU 6.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:7 (find_package):
Could not find a package configuration file provided by "ECM" (requested
version 0.0.11) with any of the following names:

ECMConfig.cmake
ecm-config.cmake

Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
to a directory containing one of the above files. If "ECM" provides a
separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/ekaradon/aur/plasma-wallpaper-himawari-git/src/plasma-wallpaper-himawari/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...
```

Have you any idea why?
Maybe some dependencies are missing like `extra-cmake-modules (extra-cmake-modules-git) (make)` ?

Cf. comments here: https://aur.archlinux.org/packages/kde-thumbnailer-blender-kf5/