Package Details: plasma5-applets-rssnow-git 1.0.r29.46e7e43-1

Git Clone URL: https://aur.archlinux.org/plasma5-applets-rssnow-git.git (read-only)
Package Base: plasma5-applets-rssnow-git
Description: Show news from various sources
Upstream URL: https://github.com/Misenko/rssnow-plasma5-applet
Keywords: applet plasma5 rss
Licenses: GPL
Conflicts: plasma5-applets-rssnow
Provides: plasma5-applets-rssnow
Submitter: misenko
Maintainer: misenko
Last Packager: misenko
Votes: 6
Popularity: 0.000000
First Submitted: 2015-10-25 10:49
Last Updated: 2015-10-28 21:33

Latest Comments

binarek commented on 2015-12-18 13:23

Plasma uses KF5 tools instead of KDE4. You should change the line prefix line to:
-DCMAKE_INSTALL_PREFIX=$(kf5-config --prefix) \

That's all I had to do to make it work

Nierro commented on 2015-10-29 13:34

Thanks!
I still had to change PKGBUILD with:
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DLIB_INSTALL_DIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
instead of yours, to make it show under "add widgets". And now it is working properly!

misenko commented on 2015-10-28 21:39

@Nierro Hi. So, I found out that I had a bug in applet's metadata and hopefully I fixed it. I tested it on a bare Arch Linux installation and it worked. Can you please test it?

About the PKGBUILD. I was following KDE package guidelines for applets
(https://wiki.archlinux.org/index.php/KDE_package_guidelines) so I think those directives you tried are not really necessary/desirable.

Nierro commented on 2015-10-26 09:55

I tried building it with:
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DLIB_INSTALL_DIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON,
same of others plasma5-applets on aur, and it now appears on add widget. But it says "Error loading Applet: package inexistent."

Nierro commented on 2015-10-25 17:52

Thanks.
I noticed that "plasmawindowed rssnow" won't start anything...even if rssnow should be the right name (pacman -Ql output i posted before should confirm this).

misenko commented on 2015-10-25 11:24

@Nierro That's strange. I'll look into it and let you know as soon as I figure out what's the problem.

Nierro commented on 2015-10-25 11:17

It is still not there (note that i rebooted too, to check).
Output of "pacman -Ql": http://pastebin.com/QLZzmg4P

misenko commented on 2015-10-25 11:15

@Nierro Are you sure about that? I've just tried it and it appears among my widgets right away. Try to run 'kbuildsycoca5' so KDE will rebuild it's cache. If it helps, I'll add it to the PKGBUILD.

Nierro commented on 2015-10-25 11:03

It seems i'm not able to find it under "add widgets" after the installation.