Package Details: python-llvmlite-git 0.43.0dev0.r0.ga6159f9-1

Git Clone URL: (read-only, click to copy)
Package Base: python-llvmlite-git
Description: A lightweight LLVM Python binding for writing JIT compilers (Git version)
Upstream URL:
Licenses: BSD
Conflicts: python-llvmlite
Provides: python-llvmlite
Submitter: guotsuan
Maintainer: bcb
Last Packager: bcb
Votes: 4
Popularity: 0.000001
First Submitted: 2014-11-30 03:15 (UTC)
Last Updated: 2024-02-27 14:48 (UTC)

Dependencies (9)

Required by (10)

Sources (1)

Latest Comments

1 2 Next › Last »

bcb commented on 2021-01-11 10:47 (UTC)

I've dropped the Python 2 package. I've also tidied up the dependencies and the provides.

petronny commented on 2020-05-04 02:50 (UTC)

Hi could you drop python2-llvmlite-git?

It doesn't build now and Python 2 is EOL.

==> Starting package_python2-llvmlite-git()...
/usr/lib/python2.7/site-packages/setuptools/ UserWarning: Normalizing '0.33.0dev0+17.gc4f5a08' to '0.33.0.dev0+17.gc4f5a08'
running install
running build
got version from VCS {'version': '0.33.0dev0+17.gc4f5a08', 'full': 'c4f5a085c9f9c7a192579b02a11347bfc2ac768b'}
running build_ext
/usr/bin/python2 /build/python-llvmlite-git/src/llvmlite-py2/ffi/
  File "/build/python-llvmlite-git/src/llvmlite-py2/ffi/", line 122
    raise ValueError(msg.format(_ver_check_skip)) from e
SyntaxError: invalid syntax
error: command '/usr/bin/python2' failed with exit status 1

petronny commented on 2019-11-30 01:29 (UTC)

python-llvmlite-git depends on llvm but python-llvmlite doesn't (it's only a make dependency). Please fix this.

flying-sheep commented on 2019-11-22 15:51 (UTC) (edited on 2019-11-22 15:54 (UTC) by flying-sheep)

@guotsuan please fix that, and also it’s --root="$pkgdir", not --root=$pkgdir

petronny commented on 2019-06-04 05:10 (UTC)

@guotsuan It's not provides=('python-llvmlite=$pkgver'). It should be provides=("python-llvmlite=$pkgver").

guotsuan commented on 2019-05-30 00:43 (UTC)

Thanks, I have fixed it.

petronny commented on 2019-05-29 06:01 (UTC)

@guotsuan So please updating provides=('python-llvmlite') to provides=("python-llvmlite=$pkgver")

flying-sheep commented on 2019-05-24 08:22 (UTC)

It does work!

petronny commented on 2019-05-23 05:58 (UTC) (edited on 2019-05-23 05:59 (UTC) by petronny)

@flying-sheep Could you confirm if this can be fixed by updating provides=('python-llvmlite') to provides=("python-llvmlite=$pkgver") in line 32?

flying-sheep commented on 2019-05-22 12:31 (UTC)

Hmm, pacman doesn’t seem to understand this version number.

With python-llvmlite-git-0.29.0dev0.r36.gd5e5cb0-1 installed, I see:

$ cd python-numba
$ makepkg -i
==> Missing dependencies:
  -> python-llvmlite>=0.28.0