Package Details: python2-pyqt4 4.12.3-1

Git Clone URL: (read-only)
Package Base: pyqt4
Description: A set of Python 2.x bindings for the Qt toolkit
Upstream URL:
Licenses: GPL
Conflicts: python2-pyqt
Provides: python2-pyqt=4.12.3
Replaces: python2-pyqt
Submitter: arojas
Maintainer: 4llan (buzo)
Last Packager: buzo
Votes: 13
Popularity: 3.124001
First Submitted: 2018-08-24 08:49
Last Updated: 2018-12-12 16:19

Dependencies (14)

Required by (134)

Sources (1)

Latest Comments

1 2 3 Next › Last »

alexei commented on 2019-02-18 19:33

As a temporary workaround, add this after both configure commands in the PKGBUILD:

find . -type f -name '*.cpp' -exec sed -i 's/{SIP_NULLPTR, SIP_NULLPTR, SIP_NULLPTR, SIP_NULLPTR}/{SIP_NULLPTR, SIP_NULLPTR, SIP_NULLPTR, 0}/g' {} \;

Btw, you also must change python-sip/python2-sip dependencies to python-sip-pyqt4/python2-sip-pyqt4, otherwise PyQt will build but the module won't work: import will fail with 'sip' not find, and if you import the default sip, you'll get errors like QtGui.QWidget no attrivute QWidget in QtGui.

Also, you must update python-sip-pyqt4/python2-sip-pyqt4 to 4.19.14 by bumping the version and URL in the PKGBUILD to . Otherwise, 'from PyQt4 import QtGui' will fail with need API v12.6 but sip provides only v12.5.

UPDATE: Also, be careful with versions of sip and python-sip-pyqt packages, it's easy to end up with different versions if you're not careful, and that's probably not good. I ended up simply adding the python-sip-pyqt4 packages to the sip source package PKGBUILD, which already has the python-sip-pyqt5; and uninstalled all sip packages from the system before building and installing the package set from the modified sip PKGBUILD. That way, all sip packages are of the same version. This does not address the underlying issue, though that PyQt4 does not build with latest sip 4.19.14.

UPDATE2: reported to PyQt4:

tchakatak commented on 2019-02-17 10:35

@kingkingmax > Can you detail more your solution? I am having the same issue.

kingkingmax commented on 2019-02-16 03:35

@ColonelThirtyTwo @sfaunl I found the issue is at sip.h Even compilier is new version, it doesn't work very well for following:

if __cplusplus >= 201103L || defined(_MSVC_LANG)

========================= / C++11 and later. /

define SIP_NULLPTR nullptr
define SIP_OVERRIDE override

/ Earlier versions of C++. /

define SIP_NULLPTR 0

============= I changed C++11 part as earlier version of C++. It works.

sfaunl commented on 2019-02-15 23:54

@ColonelThirtyTwo I'm getting same error. Downgrading gcc did not solve the problem.

ColonelThirtyTwo commented on 2019-02-14 03:33

Getting an error when I try to build this using G++ 8.2.1 (latest arch version):

g++ -c -pipe -fno-exceptions -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -Wall -W -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I. -I/usr/include/python3.7m -I../qpy/QtCore -I. -o sipQtCoreQAbstractTransition.o sipQtCoreQAbstractTransition.cpp
/home/col/.cache/pikaur/build/pyqt4/src/PyQt4_gpl_x11-4.12.3/QtCore/sipQtCoreQAbstractTransition.cpp:812:1: error: cannot convert ‘std::nullptr_t’ to ‘int’ in initialization

make[1]: *** [Makefile:698: sipQtCoreQAbstractTransition.o] Error 1
make[1]: Leaving directory '/home/col/.cache/pikaur/build/pyqt4/src/PyQt4_gpl_x11-4.12.3/QtCore'
make: *** [Makefile:60: sub-QtCore-make_default-ordered] Error 2

chrisjbillington commented on 2019-01-30 23:42

There is now an AUR package for the missing sip module, such that these packages should depend on python2-sip-pyqt4/python-sip-pyqt4. Alternately this package could be modified to include the sip module, if the maintainer has interest.

daviding commented on 2018-12-31 03:23

For anyone that needs full newbie instructions on "How to install PKGBUILD file downloaded manually?", there are now some at

inemum commented on 2018-12-14 02:15

Here are a couple of PKGBUILDs for the sip module: and

0strodamus commented on 2018-12-14 01:09

@inemum: Thanks for the tip! I created a sip PKGBUILD as you suggested and was able to get everything working again with pyqt4-4.12.3.

fraze commented on 2018-12-13 20:30

Same error as Ostrodamus. Add puddletag to the list of broken packages that depend on python-pyqt4.