Package Details: qgis-ltr 2.18.23-1

Git Clone URL: (read-only)
Package Base: qgis-ltr
Description: Geographic Information System (GIS) that supports vector, raster & database formats; Long Term Release
Upstream URL:
Keywords: GIS
Licenses: GPL
Conflicts: qgis
Provides: qgis=2.18.23
Submitter: saultdon
Maintainer: None
Last Packager: Scimmia
Votes: 12
Popularity: 1.069698
First Submitted: 2015-07-08 16:37
Last Updated: 2018-08-17 17:28

Dependencies (36)

Required by (2)

Sources (1)

Latest Comments

1 2 3 4 5 Next › Last »

rancidfrog commented on 2018-06-10 15:13

Thanks a bunch. I added for sid files the GeoExpressCLUtils- to which was conflicting with geos libraries. Removed the conf file and now it launches fine. And qgis-ltr builds fine. Thank you once again, Would not have realized that the other package also used geos.

Scimmia commented on 2018-06-10 14:44

What does ldd /usr/lib/ tell you?

rancidfrog commented on 2018-06-10 14:43

Which is found in geos package. But my geos package is up to date: community/gdal 2.3.0-1 [installed] A translator library for raster geospatial data formats community/geos 3.6.2-1 [installed] C++ port of the Java Topology Suite

and gdal is up to date too

Scimmia commented on 2018-06-10 14:34

GEOSCoordSeq_getSize_r is from

rancidfrog commented on 2018-06-10 14:29

pacman -Syu is up to date, and installing qgis worked fine from arch repo, so I assume up to date packages required by qgis are being installed. Any ideas how to locate which package is problematic?

Scimmia commented on 2018-06-10 14:22

The versions required are always the latest versions in the repos. Your packages are out of sync because they haven't all been updated, you're holding back updates, or you've replaced repo packages with other ones.

rancidfrog commented on 2018-06-10 14:20

Partial? Aren't correct pakage version of dependent libraries used on install? Which package gdal? which version required then?

Scimmia commented on 2018-06-10 14:14

That's a partial update issue. Not supported.

rancidfrog commented on 2018-06-10 14:02

When I try to install package I get:

Traceback (most recent call last):
  File "../../../../../scripts/", line 26, in <module>
    import qgis.PyQt.uic.pyuic
  File "/home/ne/.cache/aurman/qgis-ltr/src/qgis-2.18.20/build/output/python/qgis/", line 27, in <module>
    from qgis.core import QgsFeature, QgsGeometry
  File "/home/ne/.cache/aurman/qgis-ltr/src/qgis-2.18.20/build/output/python/qgis/core/", line 30, in <module>
    from qgis._core import *
ImportError: /usr/lib/ undefined symbol: GEOSCoordSeq_getSize_r
make[2]: *** [python/plugins/GdalTools/tools/CMakeFiles/zzz-GdalTools-2-depend.dir/build.make:118: python/plugins/GdalTools/tools/] Error 1
make[1]: *** [CMakeFiles/Makefile2:4346: python/plugins/GdalTools/tools/CMakeFiles/zzz-GdalTools-2-depend.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

qgis from arch package repository installs fine, but i get the same when on launch, does not start: ImportError: /usr/lib/ undefined symbol: GEOSCoordSeq_getSize_r

Any ideas why?

Scimmia commented on 2018-06-08 13:12

Whoever gave you that "fix" is an idiot. The correct fix is to rebuild against the new lib.