Package Details: saga-gis 8.5.0-2

Git Clone URL: (read-only, click to copy)
Package Base: saga-gis
Description: A Geographic Information System (GIS) software with immense capabilities for geodata processing and analysis.
Upstream URL:
Keywords: GeoSpatial GIS
Licenses: GPL3, LGPL3
Submitter: None
Maintainer: sptzmllr
Last Packager: sptzmllr
Votes: 17
Popularity: 0.059780
First Submitted: 2007-07-16 01:57 (UTC)
Last Updated: 2023-01-25 17:09 (UTC)

Latest Comments

1 2 3 4 5 6 .. 10 Next › Last »

audunmg commented on 2022-08-20 03:32 (UTC) (edited on 2022-08-20 03:33 (UTC) by audunmg)

I'm able to build 8.3.0 with these changes to PKGBUILD:

diff --git a/PKGBUILD b/PKGBUILD
index 283f77a..f035105 100755
@@ -6,36 +6,33 @@

 pkgdesc="A Geographic Information System (GIS) software with immense capabilities for geodata processing and analysis."
 arch=('i686' 'x86_64')
-depends=('wxgtk3-dev' 'proj' 'gdal' 'libtiff' 'unixodbc' 'jasper' 'swig' 'opencv' 'pdal')
-conflicts=('wxgtk3<3.1.0', 'wxgtk2<3.1.0')
+depends=('wxgtk3' 'proj' 'gdal' 'libtiff' 'unixodbc' 'jasper' 'swig' 'opencv' 'pdal')
 optdepends=('lua-hpdf' 'vigra' 'liblas' 'libharu' 'libsvm')

 build() {
   cd "${srcdir}/${_pkgname}-${pkgver}"

   [[ -d build ]] || mkdir build
+  sed -i 's/HPDF_PROJECTING_SCUARE_END/HPDF_PROJECTING_SQUARE_END/' "${srcdir}"/${_pkgname}-${pkgver}/saga-gis/src/tools/docs/docs_pdf/doc_pdf.cpp

   cd "${srcdir}/${_pkgname}-${pkgver}/build"

   cmake -G "Unix Makefiles" ../saga-gis \
   -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config   \

   msg "Start compiling ..."
-  make -j$(nproc)
+  make

 package () {

wxgtk3-dev is not required anymore, so it should be removed along with conflicts.

The cmake lines I removed are defaults, so they are not needed.

There's a typo in tools/docs/docs_pdf/doc_pdf.cpp, and it's just one line, so I just added a sed line instead of a patch since it's probably going to be fixed next version or so.

Instead of make -j$(nproc), as FabioLolix says, add MAKEFLAGS="$(nproc)" to your /etc/makepkg.conf, so all your aur packages can build fast.

dobedobedo commented on 2022-07-19 09:17 (UTC)

I can compile saga-gis with wxwidgets-gtk3 from the repo. It would be great if you can update the PKGBUILD (and to the latest version).

petronny commented on 2022-07-18 12:08 (UTC)

Hi, there is wxwidgets-gtk3 in the official repository which could replace wxgtk3-dev in AUR.

Could you test if this package can be built against wxwidgets-gtk3?

FabioLolix commented on 2022-03-13 23:59 (UTC)


  • cmake is still missing from makedepends, please build your pkgbuilds in a clean chroot for ensuring needed makedepends are present
  • using -j$(nproc) is prohibited, don't override people settings; instead configure your makepkg.conf accordingly

erydit commented on 2022-02-28 08:49 (UTC)

cmake must be in the build dependencies

geosam commented on 2022-02-28 01:05 (UTC)

Thanks @yerdung

yerdung commented on 2021-10-14 23:26 (UTC) (edited on 2021-10-14 23:32 (UTC) by yerdung)

The PKGBUILD lists wxgtk3 as a dependency, when it should really be wxgtk3-dev (or maybe wxgtk3-dev-light), since the official package only provides up to 3.0.5. If you also have wxgtk2 installed, you will need wxgtk2-dev, otherwise you won't be able to install wxgtk3-dev or wxgtk-common-dev.

Changing these two lines from the PKGBUILD should make it work for most:

depends=(wxgtk3-dev wxgtk2-dev proj gdal libtiff unixodbc jasper swig opencv pdal)
conflicts=('wxgtk3<3.1.0', 'wxgtk2<3.1.0')

The last line might not be strictly necessary, but I have no time to test if that's the case right now.

mac_arch commented on 2021-10-14 20:15 (UTC)

Hy everyone,

installation hangs in checking dependencies, in particular wxwidgets, any ideas why?

geosam commented on 2021-10-12 17:12 (UTC)

Compilation error in 8.x versions reported in:

I appreciate any corrections.

hnthang commented on 2021-09-29 02:21 (UTC)

SAGA GIS released the version 8.0 last week. When will we have the same version in AUR? I self-compiled SAGA in Lubuntu but would like to use the pre-compiled version in Manjago.

Many thanks, Thang