Package Details: shiny-server-git 1:1.5.16.958.r3.g224af58-1

Git Clone URL: https://aur.archlinux.org/shiny-server-git.git (read-only, click to copy)
Package Base: shiny-server-git
Description: Host Shiny applications over the web
Upstream URL: https://rstudio.com/shiny/server
Licenses: AGPL3
Conflicts: shiny-server
Provides: shiny-server
Submitter: hwkiller
Maintainer: a821
Last Packager: a821
Votes: 6
Popularity: 0.000000
First Submitted: 2014-01-11 06:46
Last Updated: 2021-04-25 09:05

Dependencies (7)

Required by (0)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

hwkiller commented on 2017-08-15 21:05

SataMaxx, where did you find that information? I indeed got it to compile with gcc-5, but I don't see where the issue is known upstream. Is it a node problem?

SataMaxx commented on 2017-07-31 01:39

Build fails with gcc7. This is known upstream but no fix yet.
Building from source (https://github.com/rstudio/shiny-server/wiki/Building-Shiny-Server-from-Source) works with gcc5 from the repos and exporting CC and CXX to /bin/gcc-5 and /bin/g++-5 respectively
This PKGBUILD should for now depend on gcc5, and export CC and CXX before the cmake step.

hwkiller commented on 2017-06-22 02:25

@khughitt, I will look into it asap. I haven't touched this pkgbuild in ages, so much of it may need revision. The Rstudio folks recently changed how they pull in dependencies like pandoc and the rest, so it's possible that shiny-server-git is affected by a similar change (same team maintains them).

Sorry about that.

khughitt commented on 2017-06-20 13:28

Ran into an error related to external pandoc dependency hash when attempting to build this morning:

CMake Error at external/pandoc/CMakeLists.txt:14 (file):
file DOWNLOAD HASH mismatch

for file: [/tmp/aur-shiny-server-git/src/shiny-server/tmp/external/pandoc/pandoc-1.17.2.zip]
expected hash: [b94f751c2b5023bb9b812ecb5211d7d1]
actual hash: [2bf1d83ce3bf3ae856d2af9453832952]
status: [0;"No error"]

minorsecond commented on 2016-10-31 21:25

Confirmed working. Thanks, hwkiller!

hwkiller commented on 2016-10-20 01:31

Updated; it should be working now.

hwkiller commented on 2016-09-22 07:23

Sorry for taking so long on this. Been busy with other projects.

I'll take a look at the build issues asap. Just finished working on rstudio-server-git and jasp-desktop-git. Will get to this one in the next few days.

minorsecond commented on 2016-09-21 00:48

All,

I found a workaround. I'm not sure how much work you want to put into this but it works for me.

1. Install debtap from the AUR
2. Run sudo debtap -U
3. Download the latest Shiny Server .deb (wget https://download3.rstudio.org/ubuntu-12.04/x86_64/shiny-server-1.4.4.807-amd64.deb)

4. run debtap shiny-server-1.4.4.807-amd64.deb
5. Enter your name for the packager name
6. Just press enter for the package license.
7. I didn't edit the .PKGINFO, you can just skip it (hit enter)
8. run sudo pacman -U shiny-server-1.4.4.807-1-x86_64.pkg.tar.xz

Hopefully that will get you guys all set up until the package is fixed upstream.

jjlynch commented on 2016-06-13 00:59

I'm assuming this issue is only on archlinux? So how many months will it take to resolve this? :\

hwkiller commented on 2016-06-06 03:49

I'm getting the same issue. I'm not sure it's a packaging problem.