Package Details: task-git s2.4.5.r2.g5b675ea-1

Git Clone URL: https://aur.archlinux.org/task-git.git (read-only)
Package Base: task-git
Description: A command-line todo list manager
Upstream URL: http://taskwarrior.org/projects/show/taskwarrior/
Licenses: MIT
Conflicts: task
Provides: task=2.4.4
Submitter: vali
Maintainer: vali
Last Packager: vali
Votes: 9
Popularity: 0.000000
First Submitted: 2010-07-05 23:38
Last Updated: 2015-10-22 07:59

Dependencies (13)

Required by (10)

Sources (1)

Latest Comments

tomxtobin commented on 2015-09-08 16:14

Building task-git is currently failing; branch "2.4.5" no longer exists upstream.

It builds if I edit "#branch=2.4.5" to "#branch=2.5.0" in the source URL in the PKGBUILD.

$ git clone https://aur.archlinux.org/task-git.git
Cloning into 'task-git'...
remote: Counting objects: 5, done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 5 (delta 0), reused 5 (delta 0)
Unpacking objects: 100% (5/5), done.
Checking connectivity... done.
$ cd task-git
$ makepkg
==> Making package: task-git s2.4.5.r2.g5b675ea-1 (Tue Sep 8 12:05:07 EDT 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning task-git git repo...
Cloning into bare repository '/home/tomxtobin/repo/aur/task-git/task-git'...
remote: Counting objects: 50721, done.
remote: Compressing objects: 100% (13186/13186), done.
remote: Total 50721 (delta 41089), reused 45914 (delta 37290)
Receiving objects: 100% (50721/50721), 23.53 MiB | 2.40 MiB/s, done.
Resolving deltas: 100% (41089/41089), done.
Checking connectivity... done.
==> Validating source files with md5sums...
task-git ... Skipped
==> Extracting sources...
-> Creating working copy of task git repo...
Cloning into 'task-git'...
done.
fatal: Cannot update paths and switch to branch 'makepkg' at the same time.
Did you intend to checkout 'origin/2.4.5' which can not be resolved as commit?
==> ERROR: Failure while creating working copy of task git repo
Aborting...

jck commented on 2014-09-16 09:57

The version is not being set correctly. Please use this in pkgver:
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'

x33a commented on 2014-02-12 10:36

The git urls have changed.

http://taskwarrior.org/news/189

vali commented on 2013-09-10 13:00

Thanks petelewis.

petelewis commented on 2013-09-10 12:45

Hi, the depends and optdepends have changed a bit for recent versions of this. Please check out this package for more info: https://aur.archlinux.org/packages/task-devel/

Thanks.

kostajh commented on 2013-09-09 14:58

Latest beta is 2.3.0-beta1 http://taskwarrior.org/news/179

alphazo commented on 2011-09-26 17:02

I used to be able to compile this package. Lately I'm getting the following error:

[ 30%] Building CXX object src/commands/CMakeFiles/commands.dir/CmdCommands.cpp.o
[ 32%] Building CXX object src/columns/CMakeFiles/columns.dir/ColTags.cpp.o
[ 33%] Building CXX object src/CMakeFiles/task.dir/Duration.cpp.o
/tmp/yaourt-tmp-alpha/aur-task-git/src/task.git/src/commands/CmdCommands.cpp: In constructor ‘CmdCompletionCommands::CmdCompletionCommands()’:
/tmp/yaourt-tmp-alpha/aur-task-git/src/task.git/src/commands/CmdCommands.cpp:44:18: erreur: ‘STRING_CMD_HCOMMANDS_USAGE’ was not declared in this scope
/tmp/yaourt-tmp-alpha/aur-task-git/src/task.git/src/commands/CmdCommands.cpp: In constructor ‘CmdZshCommands::CmdZshCommands()’:
/tmp/yaourt-tmp-alpha/aur-task-git/src/task.git/src/commands/CmdCommands.cpp:80:18: erreur: ‘STRING_CMD_ZSHCOMMANDS_USAGE’ was not declared in this scope
make[2]: *** [src/commands/CMakeFiles/commands.dir/CmdCommands.cpp.o] Erreur 1
make[1]: *** [src/commands/CMakeFiles/commands.dir/all] Erreur 2
make[1]: *** Attente des tâches non terminées....
[ 33%] Building CXX object src/columns/CMakeFiles/columns.dir/ColUntil.cpp.o

vali commented on 2011-07-05 13:24

Hey Chris,

there was (is) already a package called 'task' in AUR. I thiink it would be slightly confusion if the git package will be named differently.

Anonymous comment on 2011-07-05 13:12

Why not call this package 'taskwarrior-git'?

rogorido commented on 2011-02-18 13:38

sorry: it wasn't a problem of task-git, but of makepkg. It's working now. Thx for your help

rogorido commented on 2011-02-09 22:46

thx for your answers. But, I am still getting the same error... very strange:
* i have enough free disk space
* i changed 'install/strip' with 'install'

but without any success. I will watch at the bug page you sent me... thx in anycase!

vali commented on 2011-02-07 21:51

@rogorido:
Just a few ideas about your problem:
* Have you checked your free disk space?
* Could you try replacing 'install/strip' with 'install' in the PKGBUILD?

vali commented on 2011-02-07 21:39

@rogorido:
it's reported upstream: http://taskwarrior.org/issues/show/672

rogorido commented on 2011-02-05 15:40

I'm again. It's strange:

/usr/bin/makepkg: línea 268: no se puede crear un fichero temporal para el documento-aquí: Conseguido

means: a temporary file can not be created here: Success

this is a bit contradictory....

rogorido commented on 2011-02-05 15:38

yes, sorry... there are things in Spanish; sorry about that: http://pastie.org/1531289
thanks in any case for the package

vali commented on 2011-02-05 01:42

Could you please email or add a pastebin with the complete output?!

rogorido commented on 2011-02-04 23:24

I'm getting an error at compiling time:
/usr/bin/strip: unable to rename 'usr/bin/stMs3X5N'; reason: Success

thanks for providing the package!

vali commented on 2011-01-09 14:08

Changed default branch:
As mir mentioned before the master branch is the current stable release. Now task-git compiles the development branch by default as this is the expected behaviour of *-git packages.

Additionally, taskwarrior switched from autotools to cmake.

vali commented on 2010-11-09 09:35

task 1.9.3 has been released, see http://taskwarrior.org/wiki/taskwarrior/Changelog

Anonymous comment on 2010-09-10 19:03

The taskwarrior git repository does not follow the usual conventions ... if you build from the master branch, as this packages does, you get the last stable release, i.e. 1.9.2. To get the in-development version, you currently need to build from branch "1.9.3".

I changed this in the PKGBUILD and have tested for a few minutes with no apparent breakage. Has lots of new features.

(See http://taskwarrior.org/projects/roadmap/taskwarrior)

vali commented on 2010-07-15 22:43

task 1.9.2 has been released, see http://taskwarrior.org/wiki/taskwarrior/Changelog