Package Details: tinc-pre 1.1pre14-3

Git Clone URL: https://aur.archlinux.org/tinc-pre.git (read-only)
Package Base: tinc-pre
Description: VPN (Virtual Private Network) daemon (Pre-release)
Upstream URL: http://www.tinc-vpn.org/
Keywords: cryptography daemon mesh network vpn
Licenses: GPL
Conflicts: tinc, tinc-pre-systemd
Provides: tinc-pre, tinc-pre-systemd
Submitter: None
Maintainer: hexchain
Last Packager: hexchain
Votes: 11
Popularity: 0.280425
First Submitted: 2011-11-26 00:09
Last Updated: 2017-05-08 07:12

Latest Comments

maddie commented on 2017-05-09 16:05

@hexchain: You're welcome :)

hexchain commented on 2017-05-08 07:13

@maddie: Done, and thanks!

maddie commented on 2017-05-08 07:07

openssl package has been updated to 1.1, now it won't build.

please update dependency to openssl-1.0 until this is fixed upstream

FirefighterBlu3 commented on 2016-12-26 03:16

please add armv6h to arch

kseistrup commented on 2016-10-26 13:10

The provided service files are using "ExecStart=/usr/sbin/tincd" and "ExecReload=/usr/sbin/tinc -n %i reload", but both tinc and tincd are located in /usr/bin.

kseistrup commented on 2016-10-26 12:32

Please add 'armv7h' architecture to PKGBUILD so that it will build on e.g. Raspberry PI.

hexchain commented on 2016-10-26 08:51

Unflagged, because the only difference between pre13 and pre14 is the return of tinc.service. But I will definitely upgrade to pre14, and thanks for noticing.

hexchain commented on 2016-05-01 07:37

Updated to 1.1pre13.

tinc.service was removed upstream but I haven't figured out how to maintain its behavior, so I temporarily added it back.

UPDATE: upstream added tinc.service back.

hexchain commented on 2016-04-24 15:21

Starting from 1.1pre12, tinc ships its own systemd unit files, which are different from previous ones:

1. Unit file name changes from tincd(@) to tinc(@)
2. Network without network name is not supported anymore
3. tinc.service now serves to start all tinc@.service

Please reload systemd and do appropriate configuration according to these changes.

hexchain commented on 2016-02-19 14:43

Just-Punk: That error does not affect usage, but I'm trying to figure it out. Manually executing these commands in .install does not give such error. Thanks for reporting.

All comments