Package Details: trackma-git 0.8.2-1

Git Clone URL: https://aur.archlinux.org/trackma-git.git (read-only)
Package Base: trackma-git
Description: A lightweight and simple program for updating and using lists on several media tracking websites.
Upstream URL: http://z411.github.io/trackma/
Keywords: anime Hummingbird manga Melative myanimelist VNDB
Licenses: GPL3
Conflicts: wmal-git
Replaces: wmal-git
Submitter: MagicAndWires
Maintainer: MagicAndWires
Last Packager: MagicAndWires
Votes: 26
Popularity: 0.228577
First Submitted: 2014-12-15 18:06
Last Updated: 2019-05-14 21:36

Dependencies (12)

Required by (0)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

MagicAndWires commented on 2014-12-17 00:05

For the lazy, a new package can be found here[1]

[1] https://aur.archlinux.org/packages/trackma-git/

MagicAndWires commented on 2014-12-15 21:07

No problem! I'm just waiting for the merge request to get through ;)

nous commented on 2014-12-15 20:44

Please, change the OnlyShowIn directive in trackma-gtk.desktop to OnlyShowIn=GNOME;MATE;

nous commented on 2014-12-15 20:38

Scratch that, I just saw that you've already submitted a new package. Thanks for your work.

nous commented on 2014-12-15 20:36

The application name was changed from wmal to trackma. Please update the PKGBUILD, thanks.

carstene1ns commented on 2014-09-01 16:22

Yeah, using git tags for the pkgver() is of course the recommended solution. Back then, there have not been any tags.
However, note that the referenced commit bumps up the version in wmal/utils.py and not in setup.py. So the pkgver() was not affected at all.

MagicAndWires commented on 2014-09-01 12:13

I think he must have reverted that. Though the commit does show up in the log, the actual change to setup.py doesn't, and doing a 'git checkout 5bf2328ea574d7fbd09af2eed3d405a51a295a73 setup.py' doesn't show any changes either.

Might open up an issue about it later, but for now I'm keeping it on 0.2.

Thanks to pkgver() though, the local version number would have updated automatically.
Anyone who happened to have built a package when that commit was released, is probably stuck with a 0.3 package so they'll need to rebuild and "downgrade" the package.

Did notice z411 started using git tags though (bit late on that), so from now on this package will use those to determine the version number, instead of looking at setup.py, which should prevent this from happening again.

sflor commented on 2014-09-01 10:32

z411 has bumped the version number to 0.3. I just realized myself, though: https://github.com/z411/wmal-python/commit/5bf2328ea574d7fbd09af2eed3d405a51a295a73

sflor commented on 2014-06-23 16:03

Much appreciated.

MagicAndWires commented on 2014-06-23 01:59

Updated with Qt support!