Package Details: unreal-engine-bin 5.4.2-1

Git Clone URL: https://aur.archlinux.org/unreal-engine-bin.git (read-only, click to copy)
Package Base: unreal-engine-bin
Description: The world's most open and advanced real-time 3D creation tool
Upstream URL: https://www.unrealengine.com/
Keywords: 3d game-engine unreal
Licenses: custom
Conflicts: unreal-engine, unreal-engine-4, unreal-engine-git
Provides: unreal-engine
Submitter: ttc0419
Maintainer: ttc0419
Last Packager: ttc0419
Votes: 27
Popularity: 1.41
First Submitted: 2022-07-23 17:30 (UTC)
Last Updated: 2024-06-10 12:19 (UTC)

Pinned Comments

ttc0419 commented on 2022-07-23 17:34 (UTC) (edited on 2024-05-05 07:21 (UTC) by ttc0419)

To build this package, you need to:

  1. Login using you epic account and download the zip file from https://www.unrealengine.com/linux
  2. Move the zip file to the same directory as PKGBUILD and install the package using command makepkg -si

Note: Do NOT disable IPv6 as the zen server needs it to start. Please vote for the package if you think it's helpful ;-)

Latest Comments

1 2 3 4 5 Next › Last »

ttc0419 commented on 2024-06-10 04:51 (UTC)

@rabcor the url only works for limited time as it's signed by the server and you MUST agree the EULA to use the software, it's a license issue. Gnome still does not offer wayland for shell by default, I'll look into it when it does.

rabcor commented on 2024-06-09 17:06 (UTC) (edited on 2024-06-09 21:34 (UTC) by rabcor)

5.4.2 is out, by the way, why do you not just put the direct download link for the binaries in the pkgbuild? You do not actually need to be logged in for the link to work.

binarydepth, wayland support is broken, you need to recompile sdl for ue or use x11.

binarydepth commented on 2024-06-07 13:36 (UTC)

Doesn't launch complaining of video driver

rabcor commented on 2024-05-01 15:24 (UTC)

5.4.1 is out.

asessionguy commented on 2024-01-21 19:02 (UTC) (edited on 2024-01-21 19:03 (UTC) by asessionguy)

Editor wasn't starting because of wayland on GNOME 45:

[2024.01.21-18.59.06:093][ 0]LogInit: Initializing SDL. [2024.01.21-18.59.06:093][ 0]LogInit: Warning: Could not initialize SDL: wayland not available [2024.01.21-18.59.06:093][ 0]LogInit: Warning: FLinuxSplashState::InitSplashResources() : InitSDL() failed, there will be no splash. [2024.01.21-18.59.06:093][ 0]LogInit: Initializing SDL. [2024.01.21-18.59.06:094][ 0]LogInit: Warning: Could not initialize SDL: wayland not available

So I had to start it with: SDL_VIDEODRIVER=x11 /opt/unreal-engine/Engine/Binaries/Linux/UnrealEditor

SolaoBajiuik commented on 2023-11-08 23:04 (UTC)

If you can please update this to Unreal Engine 5.3.2, it would be greatly appreciated.

ruestique commented on 2023-10-24 09:39 (UTC)

sudo chmod -R a+rwX /opt/unreal-engine/Engine 🤔

ruestique commented on 2023-10-24 08:12 (UTC)

lot's of logs yelling that they haven't access - is it ok?

[2023.10.24-08.01.54:861][  0]LogUnixPlatformFile: Warning: open('/opt/unreal-engine/Engine/Content/WritePermissions.1FF2E12A788043DA8063FD0B5CE77BC6.temp', Flags=0x00080041) failed: errno=13 (Permission denied)
[2023.10.24-08.01.54:861][  0]LogUnixPlatformFile: Warning: open('/opt/unreal-engine/Engine/Content/WritePermissions.1FF2E12A788043DA8063FD0B5CE77BC6.temp', Flags=0x00080041) failed: errno=13 (Permission denied)

and i also having issue with scaling -_-

ttc0419 commented on 2023-09-30 06:44 (UTC)

@ufo_driver

liblttng-ust.so.0 is required by Engine/Binaries/ThirdParty/DotNet/6.0.302/linux/shared/Microsoft.NETCore.App/6.0.7/libcoreclrtraceptprovider.so
libicuuc.so.53 is required by Engine/Binaries/ThirdParty/ICU/icu4c-53_1/Unix/x86_64-unknown-linux-gnu/libicui18n.so
libncursesw.so.5 is required by Engine/Binaries/ThirdParty/Python3/Linux/lib/python3.9/lib-dynload/_curses.cpython-39-x86_64-linux-gnu.so

You can confirm it by extracting dynamic section of the ELF files. It does not matter what dependencies the unreal-engine use, it's about what dependencies the develop team use when they compiling the binaries. Please post on their forum if you think the dependencies are too old.