Package Details: visual-studio-code-bin 1.26.0-2

Git Clone URL: (read-only)
Package Base: visual-studio-code-bin
Description: Visual Studio Code: Editor for building and debugging modern web and cloud applications (official binary version)
Upstream URL:
Licenses: custom: commercial
Conflicts: visual-studio-code
Provides: visual-studio-code, visualstudiocode, vscode
Replaces: visual-studio-code
Submitter: dcelasun
Maintainer: dcelasun
Last Packager: dcelasun
Votes: 699
Popularity: 33.897820
First Submitted: 2017-12-18 19:14
Last Updated: 2018-08-14 06:07

Pinned Comments

dcelasun commented on 2017-11-15 06:20

FREQUENTLY ASKED QUESTIONS (read before flagging or commenting!)

  • There is a new version out, why is the package not updated?

Please check this page before flagging as out-of-date. If there is no new version on that page, it's not yet released. A tag on Github is NOT a release! If you can see the new version on the updates page but the AUR package is still not updated, flag it and give it time. It's usually done within a day or two.

  • Why is $X a dependency? I don't like it.

Just because $X is not required to open the app, doesn't mean there is nothing that depends on it. Always search the comment history on AUR to see if that dependency has been previously discussed before writing your own comment. Still nothing? Then use namcap to make sure it's really not needed. If namcap doesn't complain, please leave a comment here and I'll investigate.

  • Something is broken with the app, where do I report it?

The problem might be a packaging issue (wrong paths, dependencies, icons etc), so please write a comment here first. If you don't get a reply, or if someone says it's an upstream issue, you can report it on Github.

  • I have a problem with the package or the program itself, can I email you?

No. You won't get a reply. Leave a comment here instead and be patient.

  • What happened to visual-studio-code?

It got renamed with a -bin suffix. If you have the original package installed, you will be prompted to delete it when you install this package for the first time.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

dcelasun commented on 2018-08-14 15:56

@edoantonioco, you also need to revert the workaround commit from this package if you want to use the system glibc.

But I still don't understand why it doesn't work for you with the bundled 2.27 glibc. Are you sure you are on 1.26.0-2 of this package?

edoantonioco commented on 2018-08-14 15:46

So I went to one of the FTP servers from pacman mirrorlist and downloaded the required glibc-2.28-4, and then installed it locally.

Visual studio code still doesnt work.

dcelasun commented on 2018-08-14 12:04

@anohigisavay: glibc 2.28-1 is problematic, it breaks electron apps. That's why I have included 2.27 in the PKGBUILD. Either wait for 2.28-4 to hit [core] (which reverts the problematic bits) or use this package with an update system, which should work fine. See previous comments for details.

anohigisavay commented on 2018-08-14 11:34

@viechang: I kinda have the same issue, except GLIBC_2.28 is required by /usr/lib/ (I have built sqlite-replication from AUR to use lxd).

@dcelasun: No, contrarily, it's because the system is too new. These packages are built with glibc-2.28 but the libc provided by your PKGBUILD is 2.27.

dcelasun commented on 2018-08-14 08:08

@bulletmark, nice catch! But no, I won't bother with it since fixed glibc will be in [core] very soon.

bulletmark commented on 2018-08-14 07:19

@dcelasun, I noticed you copied my PKGBUILD except you put back the two _i686 lines which I deleted. If you are going to bother supporting 32 bit then you need to also fix the --set-interpreter line for that case.

arrufat commented on 2018-08-14 07:10

Thanks for the quickfix. I want to point out that v1.26.0 is using gtk3 file dialogs. Moreover, namcap says gtk2 is not needed anymore.

dcelasun commented on 2018-08-14 07:00

@viechang: Update your system.

viechang commented on 2018-08-14 06:53

/opt/visual-studio-code/bin/../code: /opt/visual-studio-code/glibc/usr/lib/ version `GLIBC_2.28' not found (required by /usr/lib/

dcelasun commented on 2018-08-14 06:08

The relevant glibc commit in [core] has been reverted. Updating to glibc=2.28-4 will fix it (it's currently in [testing]).

In the meantime, I've pushed a workaround.