Package Details: webstorm 2016.3.1-1

Git Clone URL: https://aur.archlinux.org/webstorm.git (read-only)
Package Base: webstorm
Description: JavaScript IDE and HTML editor.
Upstream URL: http://www.jetbrains.com/webstorm/
Licenses: Commercial
Submitter: Testuser_01
Maintainer: frederik
Last Packager: frederik
Votes: 113
Popularity: 4.091625
First Submitted: 2012-01-05 18:10
Last Updated: 2016-11-24 21:35

Required by (0)

Sources (2)

Latest Comments

frederik commented on 2016-07-15 11:14

This profile.d file makes more trouble than expected. I will remove it with the next update.

blmarket commented on 2016-07-15 01:53

Thanks, frederik.
I wanted automated way(don't modify current AUR package && upgrading/reinstalling does not change JDK),
so I created /etc/profile.d/zzz.sh (filename is important) which overrides WEBIDE_JDK. hope this help others too!

frederik commented on 2016-07-14 10:07

Hi blmarket,
to use the bundled JRE:
1. make sure that the jre was not deleted by the PKGBUILD
2. comment out the WEBIDE_JDK variable in /etc/profile.d/webstorm.sh

Cheers

blmarket commented on 2016-07-14 06:45

as this AUR package defines WEBIDE_JDK environment variable, webstorm always run with default JDK. how can I run this with different JDK? specifically, I'd like to run with Jetbrains JDK for better font rendering while keeping oracle jdk as default.

frederik commented on 2016-07-11 12:37

@pepo900 this is the stable webstorm package. For release candidates and eap releases please consider the webstorm-eap package here [1].

[1] https://aur.archlinux.org/packages/webstorm-eap/

pepo900 commented on 2016-07-11 05:47

2016.2 RC is available. Any chance of updating the package?

cardiomax2000 commented on 2016-05-23 20:22

@pablovilas thanks!!

pablovilas commented on 2016-05-23 20:14

Hello cardiomax2000,

Please run: sudo archlinux-java set java-8-jdk

cardiomax2000 commented on 2016-05-23 20:11

Hello Frederik,

I have a problem with the last version of this package:

Unsupported Java Version: Cannot start under Java 1.7.0_101-b00: Java 1.8 or later is required.

Both jre 7 and 8 are installed on my system and it seems like the wrong one is used here. Do you know I could I fix that?




Thanks for maintaining this package, it has been really useful to me :)

Wietse commented on 2016-01-31 12:00

@hobbypunk I fixed the double icon by changing the StartupWMClass from jetbrains-webstorm to jetbrains-webstormh. I changed this a week ago (with PhpStorm too) and I have not experienced this issue again.

All comments