Package Details: yle-dl-git 2.30.r7.g7baa0f6-1

Git Clone URL: https://aur.archlinux.org/yle-dl-git.git (read-only)
Package Base: yle-dl-git
Description: Download video and audio from YLE Areena.
Upstream URL: http://aajanki.github.io/yle-dl/
Keywords: areena yle
Licenses: GPL3
Conflicts: yle-dl
Provides: yle-dl=2.30.r7.g7baa0f6
Submitter: sumt
Maintainer: sumt
Last Packager: sumt
Votes: 2
Popularity: 0.068392
First Submitted: 2017-07-12 11:10
Last Updated: 2018-02-02 15:02

Latest Comments

jpalko commented on 2018-02-02 10:43

PySocks dependency should be added: $ yle-dl --help ... pkg_resources.DistributionNotFound: The 'PySocks' distribution was not found and is required by yle-dl I chose the first community version listed and got it working: community/python-pysocks 1.6.8-1 SOCKS4, SOCKS5 or HTTP proxy (Anorov fork PySocks replaces socksipy) community/python2-pysocks 1.6.8-1 SOCKS4, SOCKS5 or HTTP proxy (Anorov fork PySocks replaces socksipy)

sqfreak commented on 2018-01-12 12:54

It seems that python2-crypto is required. Without it, I get ImportError: No module named Crypto.Cipher.

sumt commented on 2017-12-23 14:39

@ZaZam yle-dl now requires python-future @jpalko if you have problems with this PKGBUILD please report them to me. If you have problems with yle-dl itself report them to the maintainer of yle-dl.

jpalko commented on 2017-12-23 12:11

Must have been something yesterday. Works fine now.

jpalko commented on 2017-12-22 18:33

Updated my system and started getting ERROR: Unsupported stream: No admissible streams for all links now. Something Yle has done now or are some python parts incompatible after the update?

ZaZam commented on 2017-12-19 21:16

I get an error with version 2.30: "pkg_resources.DistributionNotFound: The 'future' distribution was not found and is required by yle-dl" Traceback: https://pastebin.com/yM6EgfNj

Propably related to yle-dl now supporting Python 3.

sumt commented on 2017-10-13 20:52

Updated the dependencies for 2.25. Wget is now being used for downloading HTML5 streams.

drowland commented on 2017-10-13 09:44

You could also add wget to the dependencies. I somehow didn't have it on my system, and it took me a while to realise why I was getting errors (only on some downloads - maybe wget is only used on longer ones?)

sumt commented on 2017-08-08 10:07

Updated dependencies, thanks luukko! php is not required if you choose to use the alternative downloader backend (python2-youtube-dl). But by default yle-dl uses the AdobeHDS.php downloader backed that is included in yle-dl. yle-dl on aur lists it as the "old" downloader backend which IMO is incorrect, unless I'm missing something in the project documentation.

luukko commented on 2017-08-08 08:54

It seems yle-dl now also requires python2-requests and python2-progress.
The php dependencies could be made optional since yle-dl seems to work fine without them. They are optional in the yle-dl AUR package.