Package Details: zeal-git 0.6.1.r191.g803db6a-1

Git Clone URL: https://aur.archlinux.org/zeal-git.git (read-only, click to copy)
Package Base: zeal-git
Description: A simple documentation browser
Upstream URL: https://zealdocs.org/
Keywords: api dash docs docset documentation offline
Licenses: GPL3
Conflicts: zeal
Submitter: 5long
Maintainer: trollixx
Last Packager: trollixx
Votes: 74
Popularity: 0.197161
First Submitted: 2013-06-29 09:47
Last Updated: 2020-09-06 00:01

Pinned Comments

trollixx commented on 2017-09-07 18:38

Please do not flag package out of date, unless it doesn't build. It's a Git package, the version is computed during the installation.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

trollixx commented on 2016-01-15 02:32

`libwebp` is a dependency of `qt5-webkit`, so there's no need to have it here.

emerongi commented on 2016-01-01 19:53

`libwebp` is also a dependency. Build failed before I installed libwebp.

trollixx commented on 2015-11-19 02:49

This package has all correct dependencies, so there's nothing to fix. As @jdarnold has noted, for a package built directly from source repository the version number doesn't matter.

jdarnold commented on 2015-11-18 19:14

btw - you don't (usually) mark -git packages as out of date! You just "reinstall" them. The maintainer should turn off the out-of-date flag. Just because the version number in the title is wrong, doesn't make the package "out of date".

htfy96 commented on 2015-11-18 08:21

Zeal-2.0 has been released.

wolftankk commented on 2015-07-19 18:00

Build is failing for me.

g++ -c -pipe -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -pthread -pthread -std=c++0x -Wall -W -D_REENTRANT -fPIC -DZEAL_VERSION=\"0.1.2\" -DUSE_APPINDICATOR -DBUILD_QXT_GUI -DQT_NO_DEBUG -DQT_WEBKITWIDGETS_LIB -DQT_WIDGETS_LIB -DQT_WEBKIT_LIB -DQT_X11EXTRAS_LIB -DQT_GUI_LIB -DQT_SQL_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -I3rdparty/qxtglobalshortcut -isystem /usr/include/libappindicator-0.1 -isystem /usr/include/libdbusmenu-glib-0.4 -isystem /usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -isystem /usr/include/pango-1.0 -isystem /usr/include/atk-1.0 -isystem /usr/include/cairo -isystem /usr/include/pixman-1 -isystem /usr/include/libdrm -isystem /usr/include/libpng16 -isystem /usr/include/gdk-pixbuf-2.0 -isystem /usr/include/harfbuzz -isystem /usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -isystem /usr/include/freetype2 -isystem /usr/include/qt -isystem /usr/include/qt/QtWebKitWidgets -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtWebKit -isystem /usr/include/qt/QtX11Extras -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtSql -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtCore -I../.moc -I../.ui -I/usr/lib/qt/mkspecs/linux-g++ -o ../.obj/main.o main.cpp
main.cpp: In function ‘int main(int, char**)’:
main.cpp:193:29: error: variable ‘QDataStream out’ has initializer but incomplete type
QDataStream out(socket.data());
^
Makefile:903: recipe for target '../.obj/main.o' failed
make[1]: *** [../.obj/main.o] Error 1

trollixx commented on 2015-05-12 00:09

@reeling I've updated dependencies.

reeling commented on 2015-05-11 04:15

Looks like zeal now has a dependency on qt5-x11extras

cewood commented on 2015-04-11 11:47

@trollixx that was indeed the problem, apologies for the false report. I'd tried upgrading some of the items mentioned individually, but ultimately had to resort to a full upgrade to correctly align everything. Thanks for the prompt reply.

trollixx commented on 2015-04-11 08:31

@cewood Looks like your Qt dependencies are broken. Have you tried a full upgrade (pacman -Syu)?