Package Base Details: gtk3-classic

Git Clone URL: https://aur.archlinux.org/gtk3-classic.git (read-only, click to copy)
Keywords: gtk3
Submitter: jonathon
Maintainer: jonathon (lah7)
Last Packager: jonathon
Votes: 39
Popularity: 1.63
First Submitted: 2019-11-26 10:28
Last Updated: 2021-04-23 15:06

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

loto commented on 2020-05-08 05:28

The patches still apply (and work, so far) on gtk-3.24.20 - I tested by modifying the official PKGBUILD to apply the patches. I could work up a new package based on the official one - with the *.patch files, its basically a 3-4 line change, so provided the patches don't need to change a ton I should be able to keep it in sync with the official gtk3 package

TomaszGasior commented on 2020-04-25 21:05

@spayder26 When I was maintaining both gtk3-mushrooms package and gtk3-mushrooms patches, the gtk3-classic package was just gtk3-mushrooms repackaged by Manjaro people for Manjaro repository. I don't know current state but gtk3-mushrooms currently is not maintained. I mean: I am not maintainer of this project anymore and there is no activity from current maintainer.

spayder26 commented on 2020-04-25 21:02

Looks like superseeded by https://aur.archlinux.org/packages/gtk3-classic/

osch commented on 2020-04-14 15:13

With meson 0.54.0 I'm getting the error

gtk+-3.24.14/gdk/meson.build:328:2: ERROR: dependency gobject-introspection-1.0 not found

With meson 0.53.2 it builds find. Perhaps a bug in meson?

osch commented on 2020-03-01 15:27

Wow, thank you, this was fast: now it's providing gtk3=3.24.14 :-)

However I'm still having problems, I get the error messages:

:: removing gtk3 breaks dependency 'libgdk-3.so=0-64' required by light-locker

:: removing gtk3 breaks dependency 'libgtk-3.so=0-64' required by light-locker

Original gtk-3 package also provides=(gtk3-print-backends libgtk-3.so libgdk-3.so libgailutil-3.so)

After adding these to the PKGBUILD everything installs fine and seems to work :-)

osch commented on 2020-02-29 16:18

I would highly appreciate this to be updated to gtk3=3.24.14.

huyz commented on 2019-12-25 15:22

Unable to right click on file open dialog:

(org.gnome.gedit:1333102): Gtk-CRITICAL **: 23:20:55.472: gtk_popover_set_pointing_to: assertion 'GTK_IS_POPOVER (popover)' failed

(org.gnome.gedit:1333102): Gtk-CRITICAL **: 23:20:55.472: gtk_popover_popup: assertion 'GTK_IS_POPOVER (popover)' failed

robin0800 commented on 2019-12-13 18:35

Having built a cinnamon iso with gtk3-classic the theme applet won't start Putting in gtk3 instead installs a load of libraries. Themes now work. Changing back to gtk3-classic and themes still work. Is gtk3-classic missing some library depends? list of files installed by gtk3

installed lib32-dconf (0.34.0-1) installed lib32-libgudev (233-1) installed lib32-libusb (1.0.23-1) installed lib32-libgusb (0.3.1-1) installed lib32-lcms2 (2.9-1) installed lib32-cracklib (2.9.7-1) installed lib32-libtirpc (1.1.4-1) installed lib32-libnsl (1.2.0-1) installed lib32-pam (1.3.1-1) installed lib32-polkit (0.116-1) installed lib32-sqlite (3.30.1-1) installed lib32-colord (1.4.4-1) installed lib32-brotli (1.0.7-1) installed lib32-libproxy (0.4.15-2) installed lib32-glib-networking (2.62.1-1) installed lib32-libunistring (0.9.10-1) installed lib32-libidn2 (2.2.0-1) installed lib32-libpsl (0.21.0-1) installed lib32-libsoup (2.68.2-1) installed lib32-rest (0.8.1-1) Note with gtk3-classic these are all marked as orphans so I removed them expectining themes to stop working but they still work!

shmuil commented on 2019-12-12 18:40

Yes, using yay for aur. Never a problem. Have installed gtk3-mushrooms now. No problem there.

oberon2007 commented on 2019-12-12 18:14

@shmuil are you trying to install with yay by any chance? I get the same error as you when using yay, but package builds fine with makepkg.