Package Base Details: nvidia-340xx

Git Clone URL: https://aur.archlinux.org/nvidia-340xx.git (read-only, click to copy)
Submitter: simonsmh
Maintainer: JerryXiao (taz-007)
Last Packager: taz-007
Votes: 54
Popularity: 1.50
First Submitted: 2019-06-07 10:29
Last Updated: 2021-09-20 12:54

Pinned Comments

graysky commented on 2021-05-10 15:03

OK, I honestly forgot that I included an example config file. Since I don't have the hardware for testing, and since I still don't have a sense from users that it is a requirement, I will leave it in the post_install and depend on the user's ability to read pacman's output and manually copy the example over.

Latest Comments

« First ‹ Previous ... 10 11 12 13 14 15 16 17 18 19 20 ... Next › Last »

esturiano commented on 2021-02-25 04:25

I have tried different versions (from 14 to 17), with config 20-nvidia.conf, but sddm not started (not further starting systemd). Kernel 5.10 worked well for me earlier. (old iMac - GF 9400 MCP7A)

jeroni commented on 2021-02-25 03:14

Has anyone had issues with systemd message "a start job is running for /dev/dri/card0"? it ends with a crash and gdm won't start. I already had the 20-nvidia.conf file. I'm trying to boot on an old macbook with a geforce 9400M card and I'm stuck with 5.10 kernel.

graysky commented on 2021-02-25 02:35

See -17 and let me know if it needs to be tweaked.

holyArch commented on 2021-02-25 02:34

==> dkms install --no-depmod -m nvidia -v 340.108 -k 5.11.1-arch1-1 Error! Bad return status for module build on kernel: 5.11.1-arch1-1 (x86_64) Consult /var/lib/dkms/nvidia/340.108/build/make.log for more information. ==> Warning, `dkms install --no-depmod -m nvidia -v 340.108 -k 5.11.1-arch1-1' returned 10

https://0bin.net/paste/P0tarHrt#+JKStEmvHe3pCodMuY7JEkvbWRcT45-a+90TyigBCGZ

vicpt commented on 2021-02-24 22:43

@bieel1503 thank for reporting.

@graysky the package is working as it is, now it's up to you how to deal with required config files. If I can help in anything else, please say.

Thank you very much for your time maintaining this package.

bieel1503 commented on 2021-02-24 22:34

@vicpt that's it, it worked. i wonder why tho, all of a sudden. but anyway thanks for this.

vicpt commented on 2021-02-24 22:08

@bieel1503 please test with that xorg conf and report back just for @graysky confirmation.

vicpt commented on 2021-02-24 22:06

The minimal xorg config file needed to work with opengl:

Section "Files"
    ModulePath   "/usr/lib64/nvidia/xorg"
    ModulePath   "/usr/lib64/xorg/modules"
EndSection

Section "Device"
        Identifier "Nvidia Card"
        Driver "nvidia"
        VendorName "NVIDIA Corporation"
EndSection

vicpt commented on 2021-02-24 22:03

@graysky as I thought it is indeed a xorg server related problem. The patches in -16 are good, keep the historical patches.

So, in sum the package is ok. But a mention to alert users for the need of xorg config file would be good.

A post_install message or even a script to install a minimal config file on demand should be the best solution in my opinion.

graysky commented on 2021-02-24 21:07

OK... I'll leave it to you guys to figure it out. If it is a config option, I will add a post-install and provide an example. Keep me updated.