summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsvenschneider2013-10-30 00:14:49 +0100
committersvenschneider2013-10-30 00:14:49 +0100
commitb3cddb3dffdc18064085cbbacd07a86cdfe604ed (patch)
treefedb5d03c39cb7229c3fd067f0788c4f1aab4c56 /PKGBUILD
parenta4f48153b5897d80cf7c26064547ddb3998bb158 (diff)
downloadaur-orocos-rtt-omniorb.tar.gz
[orocos-rtt-omniorb] unset ros variables before building and enable testing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3852f7591d69..58b65fb4a5e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=orocos-rtt-omniorb
_pkgname=orocos-toolchain
pkgver=2.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="Open Robot Control Software is a tool to create real-time robotics applications using modular, run-time configurable software components (Real-Time Toolkit)"
arch=('i686' 'x86_64')
url="http://www.orocos.org/rtt"
@@ -33,7 +33,8 @@ build() {
# update the cmake configuration file so that it finds the RTT
sed 's/set(OROCOS-RTT_FOUND ${OROCOS-RTT_IMPORT_FILE})/set(OROCOS-RTT_FOUND TRUE)/g' -i orocos-rtt-config.cmake
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_CORBA=ON -DCORBA_IMPLEMENTATION=OMNIORB .
+ unset -v ROS_ROOT
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DENABLE_TESTING=ON -DENABLE_CORBA=ON -DCORBA_IMPLEMENTATION=OMNIORB .
make
}