Package Details: aurutils 3.1.2-2

Git Clone URL: https://aur.archlinux.org/aurutils.git (read-only, click to copy)
Package Base: aurutils
Description: helper tools for the arch user repository
Upstream URL: https://github.com/AladW/aurutils
Keywords: aur
Licenses: custom:ISC
Submitter: Alad
Maintainer: Alad (runical, cgirard, maximbaz)
Last Packager: maximbaz
Votes: 180
Popularity: 3.88
First Submitted: 2016-03-26 19:17
Last Updated: 2021-01-04 20:31

Pinned Comments

Alad commented on 2020-11-09 13:17

AUR_LIB_DIR was not correctly subsituted in aurutils 3.1.1. The fix is in 3.1.2. To update:

git clone https://aur.archlinux.org/aurutils.git
cd aurutils
/usr/lib/aurutils/aur-build

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

nirnakinho commented on 2020-10-29 17:37

The build fails because signify is missing. I guess signify should be added as a makedep.

Regards,

kaurman commented on 2020-09-21 15:34

Makes perfect sense. Thank you!

maximbaz commented on 2020-09-21 15:27

Since 2.3.5 was broken you can't use it to build the latest version, upgrade using makepkg

kaurman commented on 2020-09-21 14:42

I can confirm what FernandoBasso said. 2.3.6b-1 fails to install.

FernandoBasso commented on 2020-09-21 09:54

2.3.6b, and still this:

$ aur sync --upgrades
==> Using [aurpkgs] repository
  -> aurutils: 2.3.5-1 -> 2.3.6b-1
==> Retrieving package files
From https://aur.archlinux.org/aurutils
 = [up to date]      master     -> origin/master
Running makepkg --clean --syncdeps
==> ERROR: build: invalid argument (no packages found)

Is it still expected for 2.6.3b or it is something wrong on my end?

Alad commented on 2020-09-19 16:43

Fixed in 2.3.6

Mel commented on 2020-09-19 11:58

Starting with 2.3.5 aur build and aur sync operations error out with

~ ▶ aur sync --rebuild --no-view aurutils
==> Using [loonix] repository
==> Retrieving package files
From https://aur.archlinux.org/aurutils
 = [up to date]      master     -> origin/master
Running makepkg --clean --syncdeps
==> ERROR: build: invalid argument (no packages found)
~ ▶ 

ArchPCK commented on 2020-09-05 16:36

To make it build, import alads key from pacman keychain:

pacman-key --export DBE7D3DD8C81D58D0A13D0E76BC26A17B9B7018A | gpg --import

merlock commented on 2020-08-20 21:26

@rafaelff:

The "ERROR..." is what I am talking about. I inserted multiple blank lines after that to show that the first package installed just fine without error.

I do note that I should've used '--list-keys' instead, but that's really a moot point, because the key in question is my key. (Note the 'Signing package(s)... and 'Created signature file...' lines above the error).

rafaelff commented on 2020-08-20 16:22

@merlock: Actually, do you mean ERROR: The key F24B2F77 does not exist in your keyring. ? If yes, then notice how right after this error message, the GPG key is added via gpg --recv-keys F24B2F77. Looks good to me.