Package Details: autofirma-git r6411.52b796b29-1

Git Clone URL: https://aur.archlinux.org/autofirma-git.git (read-only, click to copy)
Package Base: autofirma-git
Description: Cliente de firma electrónica ofrecido por la Administración Pública
Upstream URL: https://firmaelectronica.gob.es/
Licenses: GPL, custom:EUPL
Conflicts: autofirma, autofirma-bin
Submitter: ogarcia
Maintainer: ogarcia
Last Packager: ogarcia
Votes: 1
Popularity: 0.012656
First Submitted: 2021-05-18 13:48 (UTC)
Last Updated: 2021-12-24 14:50 (UTC)

Dependencies (4)

Required by (0)

Sources (8)

Latest Comments

1 2 Next › Last »

ffcc commented on 2021-12-24 15:40 (UTC)

Perfecto, compila sin problemas.

Muchas gracias ogarcia.

ogarcia commented on 2021-12-24 14:55 (UTC)

@ffcc acabo de hacer un pequeño "mix" de tu idea con el repositorio de jmulticard de tal forma que se compila tambien la version 1.7 y la 1.8-SNAPSHOT. Eso si, he tenido que rebuscar por el repositorio donde estaba cada versión porque los colegas del CTT se han olvidado de poner tags...

Ahora mismo ya compila este paquete autofirma-git y el autofirma. El autofirma-bin evidentemente no puedo actualizarlo puesto que no hay binario de la 1.7.2.

ogarcia commented on 2021-12-24 13:35 (UTC)

@ffcc me has dado una idea loquisima, voy a desarrollarla un poco a ver que saco, dame un rato

ffcc commented on 2021-12-24 11:50 (UTC) (edited on 2021-12-24 15:40 (UTC) by ffcc)

Buenas, parece que falta el archivo jmulticard-base-1.7.pom en el repositorio. He copiado el de jmulticard-base-1.6.pom y cambiado la version 1.6 a 1.7. He tenido que cambiar además el pom.xml de algún plugin:

afirma-server-simple-webstart/pom.xml -> Cambiar ademas del source y el target, la version de maven-war-plugin:
<artifactId>maven-compiler-plugin</artifactId>
<version>3.1</version>
<configuration>
<source>1.7</source>
<target>1.7</target>
...
<artifactId>maven-war-plugin</artifactId>
<version>3.3.1</version>

afirma-signature-retriever/pom.xml -> Cambiar el source y el target
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.7</source>
<target>1.7</target>


afirma-signature-storage/pom.xml -> Cambiar el source y el target
<artifactId>maven-compiler-plugin</artifactId>
<version>3.7.0</version>
<configuration>
<source>1.7</source>
<target>1.7</target>

Con estos cambios el software compila y funciona (acabo de firmar un documento online para la administración y ha funcionado).

usuariopolivalen commented on 2021-12-05 19:48 (UTC)

no es urgente, lo tengo ya construido y antes al menos funcionaba, solo quería comentar que no se podía compilar, no te preocupes de momento, veremos si lo arreglan, de momento sigue sin ir.

ogarcia commented on 2021-12-02 08:09 (UTC) (edited on 2021-12-02 08:23 (UTC) by ogarcia)

@usuariopolivalen eso es porque han fusionado los cambios de la versión actualizada de windows en el master sin haber subido el artefacto correspondiente. Ya abrí un bug sobre ese tema hace un mes pero poco caso han hecho.

Los cambios parece que son los introducidos en este commit.

Lo único que se me ocurre es intentar crear el paquete utilizando este zip que es justo antes de que metieran esos cambios.

ACTUALIZACIÓN: Si puedes construir el paquete usando ese zip. Dejo aqui un PKGBUILD modificado para que pueda hacerse.

usuariopolivalen commented on 2021-12-02 00:47 (UTC)

me iba, me iba, muchas gracias, lo que si te digo que al intentar actualizar hoy me ha salido : [INFO] afirma-crypto-xadestri-client ...................... SKIPPED [INFO] afirma-crypto-jarverifier .......................... SKIPPED [INFO] afirma-keystores-capiaddressbook ................... SKIPPED [INFO] afirma-keystores-filters ........................... SKIPPED [INFO] afirma-keystores-mozilla ........................... SKIPPED [INFO] afirma-keystores-single ............................ SKIPPED [INFO] afirma-ui-core-jse-keystores ....................... SKIPPED [INFO] afirma-core-massive ................................ SKIPPED [INFO] afirma-server-triphase-signer-cache ................ SKIPPED [INFO] afirma-server-triphase-signer-core ................. SKIPPED [INFO] afirma-server-triphase-signer-document ............. SKIPPED [INFO] afirma-ui-simpleafirma-plugins ..................... SKIPPED [INFO] afirma-ui-simpleafirma-plugin-hash ................. SKIPPED [INFO] afirma-ui-simpleafirma-plugin-validatecerts ........ SKIPPED [INFO] ------------------------------------------------------------------------ [INFO] BUILD FAILURE [INFO] ------------------------------------------------------------------------ [INFO] Total time: 19.411 s [INFO] Finished at: 2021-12-02T01:38:57+01:00 [INFO] ------------------------------------------------------------------------ [ERROR] Failed to execute goal on project afirma-core-keystores: Could not resolve dependencies for project es.gob.afirma:afirma-core-keystores:jar:1.8-SNAPSHOT: Failed to collect dependencies at es.gob.afirma.jmulticard:jmulticard:jar:1.7: Failed to read artifact descriptor for es.gob.afirma.jmulticard:jmulticard:jar:1.7: Could not find artifact es.gob.afirma.jmulticard:jmulticard-base:pom:1.7 in central (https://repo.maven.apache.org/maven2) -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException [ERROR] [ERROR] After correcting the problems, you can resume the build with the command [ERROR] mvn <args> -rf :afirma-core-keystores ==> ERROR: Se produjo un fallo en build(). Cancelando...

PD: no es urgente al menos de momento, a ver si actualizan la version anterior que es de verguenza vaya...

ogarcia commented on 2021-11-02 10:37 (UTC)

@usuariopolivalen ya contarás si funciona o no con el dnie 4

usuariopolivalen commented on 2021-11-02 10:02 (UTC)

@ogarcia ya me compila, no lo he testado a ver si va con el dnie v4.. que me lo saque hace poco y el otro dia me vencio una fecha por la jodida incompatibilidad de autofirma( lo digo por el gob no por ti eh)

ogarcia commented on 2021-10-31 12:58 (UTC)

@usuariopolivalen es un problema en el upstream, ya he abierto bug.

De todas formas, como no se cuanto pueden tardar en solucionar el tema, le he metido un parche en el PKGBUILD por lo que ya te debería compilar sin problema.