Package Details: codelite 9.2-1

Git Clone URL: (read-only)
Package Base: codelite
Description: Open-source, cross platform IDE for the C/C++ programming languages
Upstream URL:
Licenses: GPL
Submitter: None
Maintainer: uffe
Last Packager: uffe
Votes: 133
Popularity: 3.768919
First Submitted: 2008-08-01 09:11
Last Updated: 2016-08-01 11:38

Latest Comments

zerophase commented on 2016-08-02 03:58

@fusion809 Is Clang 3.8 required to open Codelite? With having Clang as a required dependency it prevents changing Clang versions from the official repos.

fusion809 commented on 2016-08-01 13:26

Ah clang is listed as both an optional and runtime dependency. I think it should be listed as a runtime or optional dependency. As if someone has this package installed and it's a runtime dependency they should already have the package installed and hence it isn't really an optional dependency.

zerophase commented on 2016-07-30 16:45

I'm just referring to clang 3.8 as being a necessary dependency for building the ide. would it make sense to have clang as a makedepend?

uffe commented on 2016-07-30 11:56

Yes, if you have clang-3.5 installed - go into menu Settings -> Build settings...
In the dialog you can scan your computer for the compilers that you have installed.

Select the one you prefer..

zerophase commented on 2016-07-29 23:18

Does 9.2-1 compile with clang 3.5? On occasion I need to drop back to clang 3.5 for a custom Unreal build.

uffe commented on 2016-02-06 00:05

Updated to codelite 9.1.0

norby commented on 2015-10-27 15:41

Thanks, nickname!

I thought that this problem is resolved in the latest version, so I left out the comments.

P.S. Sorry for my bad English :(

nickname commented on 2015-10-26 17:25

Hi norby.
This happens (most probable) because of the lldb 3.7 version.

See the two different solutions uffe provides on the comments below

the other logs (mismatch) are displayed every time anyway

norby commented on 2015-10-26 17:16

The application fails to start:

Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8)

uffe commented on 2015-10-23 08:43

bumped to 9.0

All comments