Package Details: easyrpg-player-git 0.8.r306.gb313163f5-1

Git Clone URL: https://aur.archlinux.org/easyrpg-player-git.git (read-only, click to copy)
Package Base: easyrpg-player-git
Description: FLOSS RPG Maker 2000/2003 and EasyRPG games interpreter (development version)
Upstream URL: https://easyrpg.org
Keywords: 2k 2k3 role-playing-game
Licenses: GPL-3.0-or-later
Conflicts: easyrpg-player
Provides: easyrpg-player
Submitter: carstene1ns
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 7
Popularity: 0.000000
First Submitted: 2013-07-01 20:02 (UTC)
Last Updated: 2024-04-26 18:06 (UTC)

Dependencies (24)

Required by (8)

Sources (1)

Latest Comments

1 2 Next › Last »

axzxc1236 commented on 2021-10-31 00:38 (UTC) (edited on 2021-10-31 00:40 (UTC) by axzxc1236)

The version name is a little different then what is generated by makepkg, makes yay (AUR helper) thinks there are always updates.

Version in PKGBUILD: 0.7.0.r0.g281be71fe
Version number generated by makepkg: 0.7.0.r0.g281be71f

Same thing is happening to liblcf-git

carstene1ns commented on 2021-10-30 18:44 (UTC)

unknown78: Also your liblcf-git is not new, since 0.7 has been out (this should not matter, though).

lithium_sulfate commented on 2021-10-27 06:22 (UTC)

unknown78: I was getting similar linker errors until I disabled or cleared my ccache, after that the package built fine. Building in a clean chroot also worked.

unknown78 commented on 2021-10-25 07:08 (UTC)

Currently the following error while linking happens -> /usr/bin/ld: libeasyrpg-player.a(libeasyrpg_player_a-game_map.o): in function Game_Map::loadMapFile(int)': game_map.cpp:(.text+0xb41f): undefined reference tolcf::LMU_Reader::Load(std::istream&, std::__cxx11::basic_string<char, std::char_traits\<char>, std::allocator\<char> > const&)'

liblcf-git is newest -> 0.6.2.r202.gc21cfec-1

carstene1ns commented on 2021-09-11 12:12 (UTC)

unknown78: Upstream fix is here, will be merged soon: https://github.com/EasyRPG/Player/pull/2644

unknown78 commented on 2021-09-05 17:21 (UTC)

I have the following error while compiling -> libvorbis is from main.

ar: u' modifier ignored sinceD' is the default (see `U') CXXLD easyrpg-player /usr/bin/ld: libeasyrpg-player.a(libeasyrpg_player_a-decoder_oggvorbis.o): undefined reference to symbol 'vorbis_comment_query' /usr/bin/ld: /usr/lib/libvorbis.so.0: error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status

carstene1ns commented on 2021-07-20 21:08 (UTC)

unknown78: Right, we recently removed sdl2_mixer and broke a part of fmmidi. This needs an upstream fix. Package should work as of 0.6.2.r1294.

unknown78 commented on 2021-07-20 16:01 (UTC)

i get the following error trying to build easyrpg-player-git -> #error "WANT_FMMIDI must be set to 1 for non-SDL Mixer builds"

local/sdl2_mixer 2.0.4-6 << is installed

carstene1ns commented on 2021-01-06 20:28 (UTC)

unknown78: You need to rebuild liblcf-git. This constant was added 4 months ago.

unknown78 commented on 2021-01-06 07:55 (UTC)

I get the following error when trying to build -> https://termbin.com/lin4