Package Details: eddie-ui 2.21.6-1

Git Clone URL: (read-only, click to copy)
Package Base: eddie-ui
Description: Eddie - VPN tunnel - UI
Upstream URL:
Licenses: GPLv3
Conflicts: airvpn, airvpn-beta-bin, airvpn-git
Provides: eddie-ui
Last Packager:
Votes: 11
Popularity: 0.69
First Submitted: 2018-05-20 19:09 (UTC)
Last Updated: 2022-05-02 09:47 (UTC)

Latest Comments

Koboldz commented on 2022-05-14 00:57 (UTC)

I Edited PKGBUILD and uncomment the lines 47-53 (line 45-46 are a comment and shouldnt uncommented). I build AUR Package and overwrite my install files in /usr/bin/, /usr/lib/ and in /usr/share/

The tray icon is still missing, even after a system restart... it just won't show up. Im still using Manjaro KDE... please help. What can i do to fix this?

Here is also my help Topic/Request in Manjaro Forum:

opensorcerer commented on 2022-05-08 15:06 (UTC)

Thanks for the tip, but why was the feature removed in the first place?

As stated in the PKGBUILD:

# Removed in 2.21.5, compatibility issue

It is mentioned that it's difficult to find a build config that works flawlessly on all Arch distributions (the Arch, but also Endeavour, Garuda and Manjaro), which means, the maintainers of this PKGBUILD are trying to target them all. One can deduce that the mentioned compatibility issue stems directly from the fact they're trying to target them all: It works in some but not in other distributions.

lencho commented on 2022-05-07 14:11 (UTC)

Thanks for the tip, but why was the feature removed in the first place?

opensorcerer commented on 2022-05-06 11:34 (UTC)

How do i solve this problem now?

Edit the PKGBUILD and uncomment lines 45-53. Then simply build and install your custom package over the "official" version.

Koboldz commented on 2022-05-03 20:29 (UTC) (edited on 2022-05-03 20:30 (UTC) by Koboldz)

@opensorcerer And what is the solution? How can i hide the client Window with the newest version? I don't want a always visible Window in my Taskbar, this is a downgrade.

The Option under Preference>GUI>Minimize to Tray is still there, but its not working.

How do i solve this problem now?

opensorcerer commented on 2022-05-03 18:37 (UTC)

@Koboldz that is because Eddie-Tray is not built anymore, see the changelog for the 2.21.6 commit for reasons. ;)

Koboldz commented on 2022-05-03 01:17 (UTC)

I Updated today Eddie UI (AUR) from 2.20 to 2.21.6 and with the new version the Tray Icon is missing. I can no longer minimize the Eddie Window into tray, i played with the GUI settings but no success.

Im using Manjaro KDE with the 5.15.32 LTSC Kernel.

opensorcerer commented on 2021-11-29 09:17 (UTC)

Issue confirmed, please refer to AirVPN Staff's post.

8xen8 commented on 2021-11-29 02:07 (UTC)

network lock works with kernel 5.10.82-1-lts but 5.15 doesnt work.

TheEgg commented on 2021-11-28 09:53 (UTC)

I get the same as @lencho, unable to start network lock

lencho commented on 2021-11-28 09:34 (UTC)

I confirm what magnavoid says, same here, network lock does not work. When I start Eddie, I get this message: "Exception: iptables don't reply, probabily kernel modules issue" (sic)

For the rest, it seems to still work fine.

magnavoid commented on 2021-11-28 03:25 (UTC)

Started having issues with eddie after a recent kernel upgrade. Network lock does not appear to be working correctly or at all.

opensorcerer commented on 2021-04-17 21:06 (UTC)

Since we've got some hummingbird packages in the AUR and people can optionally choose to use Hummingbird in the client via a simple switch in Preferences, one could think about adding one of those to optdepends.

j.mlr commented on 2020-11-21 21:01 (UTC), I am using eddie-ui-git (2.19.6-1) and yes the sudo prompt in CLI mode works. Thanks! commented on 2020-11-12 15:23 (UTC)

Hi @j.mlr

Eddie will try to find your profile in /usr/lib/eddie-ui because for portable-edition reason, if Eddie can write in it's folder, use it as default path. You can override the path with "-path".

  • You can use "eddie-ui -cli -profile=my_profile -path=/home/<your>/.config/eddie" to avoid symlink. Anyway, i don't think it's a right method, because profile file will be saved as root.

Anyway, i confirm there are something don't work as expected, please try the latest 2.19.6, we fixed an issue related to sudo prompt in CLI mode. If 2.19.6 works for you, you don't need anymore custom path or symlink or launch with 'sudo'.

Anyway-bis, at least in the latest beta 2.19.6, if you tick "Don't ask elevation" in Preferences -> General, a systemd service is installed, and after with CLI don't need to ask elevation.

AUR repository will be upgraded soon. In the meantime you can find the latest beta at -> Linux -> Arch -> Other Versions -> Experimental, packages as tar.zst files (to install with pacman -U <file>). We also made a new package that is CLI only, launched with "eddie-cli".

j.mlr commented on 2020-11-01 15:29 (UTC) (edited on 2020-11-03 15:19 (UTC) by j.mlr)

I posted it on the page of the beta version, but I believe it applies to the stable release as well:

The CLI tool had some issues on my system which are easily fixable.

When I launched the CLI tool with eddie-ui -cli, it told me "Unable to find a method to run elevated process" and I couldn't find a way to fix this per se.

When I launched it with sudo, it couldn't find my profile and shut down instantly. I believe, if you launch the CLI tool with sudo, it will try to find your profiles in the wrong directory (/usr/lib/eddie-ui/ instead of ~/.config/eddie/).

There are two solutions:

(1) You can launch the CLI tool with the AirVPN username and password as arguments, but it will be visible in the terminal history so it is not a good idea.

(2) Create a symlink so that the CLI tool can find the correct profile, then pass the name of the profile as an argument when launching the CLI tool:

sudo ln -s ~/.config/eddie/default.profile /usr/lib/eddie-ui/my_profile.profile

sudo eddie-ui -cli profile=my_profile

lencho commented on 2020-07-23 18:50 (UTC)

2.19.4 works for me on KDE - Manjaro. Thanks for the fix.

alnimsawy commented on 2020-04-19 07:59 (UTC)

I can confirm: version 2.16.x still works fine - as @lencho mentioned, you can download it from the website (compiled) - thanks!

lencho commented on 2020-04-18 08:24 (UTC)

Luckily, for the record, you can easily get older versions from the website:

alnimsawy commented on 2020-04-18 06:56 (UTC)

The GUI is broken on Manjaro KDE (same goes for opensuse as I heared) on 2.18x or 2.19x. It worked well with the previous version 2.16. Would it be possible to add a downgrade version (2.16.3 I guess) to AUR?

polygamma commented on 2020-04-10 18:47 (UTC) with your bump to "2.19.0" you have solved the cd issue but you forgot to update the pkgver, source, sha1sums and you also did not push a new .SRCINFO. Compare with commented on 2020-04-10 13:02 (UTC)

package fixed, sorry.

@frcr: you are right, sad choice because different package (stable, git, internal etc) have different subfolder name, anyway we fix it. @isgy: in my Arch msbuild is not available, only xbuild. @andrewchen: difficult to maintain every package-system (deb, rpm, aur etc), will be investigated, anyway you tell that we don't need to call update-desktop-database anymore? Thx

zebulon commented on 2020-04-09 19:58 (UTC)

@lencho: yes I have the same issue with airvpn-bin package, which is the same, as far as I understand.

lencho commented on 2020-04-08 20:09 (UTC)

I confirm package for 2.18.9 is broken ('cd' issue mentioned below), installing from source works but I get graphical issues I did not have with 2.16 (no visible text in the UI and buttons and controls are wrong size). Has a dependency changed, for a mono package or something? Same with 2.19-git.

KeeperB5 commented on 2020-04-08 05:04 (UTC)

Package still broken, using eddie-ui-git instead, which works.

frcr commented on 2020-04-03 18:33 (UTC)

This would be pretty funny if only it wasn't so sad

-  cd "Eddie-$pkgver"
+  cd * # First folder

KeeperB5 commented on 2020-04-03 17:23 (UTC) (edited on 2020-04-03 17:25 (UTC) by KeeperB5)

The latest eddie-ui won't install.

==> Validating source files with sha1sums...
    2.18.9.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting 2.18.9.tar.gz with bsdtar
==> Starting build()...
/var/tmp/pamac-build-user/eddie-ui/PKGBUILD: line 33: cd: too many arguments
==> ERROR: A failure occurred in build().

juhkjd43 commented on 2019-04-02 22:11 (UTC) (edited on 2019-04-02 22:11 (UTC) by juhkjd43)

@isgy: Good remark.

Will we get an updated PKGBUILD soon?

isgy commented on 2019-01-29 15:14 (UTC)

this package should be using msbuild and not the deprecated xbuild for Mono builds.

andrewchen commented on 2018-06-01 23:07 (UTC)

The .install file (to update desktop mime databse) is not needed anymore with pacman hooks.