Package Details: etlegacy-mod 2.81.0-1

Git Clone URL: (read-only, click to copy)
Package Base: etlegacy
Description: Wolfenstein: Enemy Territory 2.60b compatible client/server (etlegacy mod)
Upstream URL:
Licenses: custom, GPL3
Submitter: vorot93
Maintainer: jorgicio
Last Packager: jorgicio
Votes: 18
Popularity: 0.000006
First Submitted: 2015-08-17 02:35 (UTC)
Last Updated: 2023-02-09 23:41 (UTC)

Latest Comments

1 2 3 Next › Last »

jorgicio commented on 2023-02-09 23:42 (UTC)

'cjson' added as a dependency. Thanks!

wooptoo commented on 2023-02-09 22:29 (UTC)

cjson is also required to build this.

vetu104 commented on 2022-08-31 22:55 (UTC)

At the time of this comment, game needs to be run with environment variable SDL_FRAMEBUFFER_ACCELERATION=false

Otherwise it will crash on launch.

jorgicio commented on 2021-08-18 18:05 (UTC)

Missing dependency added. Please resync and try again. Thanks, @Lucki.

Lucki commented on 2021-08-17 22:42 (UTC)

I get the following error in a clean chroot:

-- Found OpenAL: /usr/lib/ (Required is at least version "1.14") 
-- Found Vorbis: /usr/include  
CMake Error at /usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find Theora (missing: THEORA_LIBRARY THEORA_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.21/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  cmake/FindTheora.cmake:50 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  cmake/ETLSetupFeatures.cmake:221 (find_package)
  CMakeLists.txt:137 (include)

-- Configuring incomplete, errors occurred!
See also "/build/etlegacy/src/etlegacy-2.77.1/CMakeFiles/CMakeOutput.log".
See also "/build/etlegacy/src/etlegacy-2.77.1/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().

PongTea commented on 2020-11-22 16:14 (UTC) (edited on 2020-11-22 16:35 (UTC) by PongTea)

etlegacy-git 2.76.810.g164b964c3-1 compiles indeed successfully but there is another issue affecting only 64bit patched clients (above v.2.76).

TL;DR: 64bit patched client need to connect to a patched server.

Details: quoting upstream

[...]in case you will attempt to connect to 2.76 server [with a patched client] and be forced to download the 2.76 paks, you will run into the issue [which is game crash]. There is nothing to do about it, you can instead compile or use 32 bit executable, since the problem only affects 64bit binaries.

And also, quoting upstream

Currently only official and one custom server supports patched binary.

gboehl commented on 2020-11-17 22:10 (UTC)

I have the same problem. The git version works though.

PongTea commented on 2020-11-12 10:52 (UTC) (edited on 2020-11-16 21:30 (UTC) by PongTea)

Fails to build, log is here

Edit: corrected link (posted the wrong log). While I'm at it, someone reported the build failure upstream

starmatt commented on 2020-08-27 10:15 (UTC) (edited on 2020-08-27 10:21 (UTC) by starmatt)

I'm having the same issue as user Traace, the compilation fails at 40%

[ 40%] Linking C shared module
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x25260): multiple definition of `shader'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x25260): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0xe860): multiple definition of `stages'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0xe860): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x20): multiple definition of `implicitMap'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x20): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x4): multiple definition of `implicitStateBits'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x4): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x0): multiple definition of `implicitCullType'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x0): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x25248): multiple definition of `dshader'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x25248): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x251e0): multiple definition of `table'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x251e0): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x60): multiple definition of `texMods'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x60): first defined here
/usr/bin/ld: CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader_r1.c.o:(.bss+0x25520): multiple definition of `shaderHashTable'; CMakeFiles/renderer_opengl2_x86_64.dir/src/renderer2/tr_shader.c.o:(.bss+0x25520): first defined here
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/renderer_opengl2_x86_64.dir/build.make:858:] Error 1
make[1]: *** [CMakeFiles/Makefile2:187: CMakeFiles/renderer_opengl2_x86_64.dir/all] Error 2
make: *** [Makefile:171: all] Error 2
==> ERROR: A failure occurred in build().
error making: %!s(func() string=0x557790cf0a60)

Anyone knows how to fix this? Thanks.

nicolino commented on 2020-06-22 12:31 (UTC)

After compilation.

       0 Sys_LoadGameDll -> FS_CL_ExtractFromPakFile(/home/zema/.etlegacy, legacy,
       0 Sys_LoadDll(/usr/lib/etlegacy/legacy/ failed: /usr/lib/etlegacy/legacy/ cannot open shared object file: No such file or directory
       0 Sys_LoadDll(/home/zema/.etlegacy/legacy/ failed: /home/zema/.etlegacy/legacy/ undefined symbol: __acosf_finite