Package Details: gconf 3.2.6+11+g07808097-6

Git Clone URL: https://aur.archlinux.org/gconf.git (read-only, click to copy)
Package Base: gconf
Description: An obsolete configuration database system
Upstream URL: https://projects-old.gnome.org/gconf/
Licenses: LGPL
Submitter: arojas
Maintainer: yan12125 (lilac)
Last Packager: lilac
Votes: 16
Popularity: 7.59
First Submitted: 2020-01-02 20:47
Last Updated: 2020-01-03 09:41

Required by (472)

Sources (7)

Pinned Comments

flying-sheep commented on 2020-01-06 19:20

Most of the packages that “require” it are actually Electron apps that copy&pasted their dependency lists from elsewhere or failed to update them: Chromium (and subsequently Electron) haven’t been dependent on this for years.

If you want to help, you can ask the maintainers of all those apps if they really still need gconf.

None that I use still need it (spotify and hamsket-bin), and their maintainers removed the superfluous dependency.

yan12125 commented on 2020-01-04 15:18

If you got build issues, please make sure you are using clean chroots[1] to build it. If you don't want to create clean chroots, make sure base-devel group is installed[2], so that you have tools like automake and pkg-config.

AUR helper like yay or pacaur may not be able to build this package. Specifically, pacaur is known to be broken: https://github.com/E5ten/pacaur/issues/14.

[1] https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot

[2] https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

Latest Comments

1 2 Next › Last »

insane commented on 2020-01-22 12:18

I've had an issue with missing introspection.m4 module while building gconf. It turns out gobject-introspection package was needed, not sure if it's due to my system or its global but it may help for others like me.

src530 commented on 2020-01-13 13:31

aur/gconf 3.2.6+11+g07808097-5 5 -> 6

==> ==> ERROR: unable to update No database errors have been found!

WTF???

frcl commented on 2020-01-11 17:28

Could you add automake as a make dependency? I got the following error message

/usr/bin/gnome-autogen.sh
checking for automake >= 1.9...
  testing automake... not found.
    Aborting...

Of cause installing the automake solved it.

gjvnq commented on 2020-01-11 00:08

You need to install gnome-common from GNOME SVN and make
sure the gnome-autogen.sh script is in your $PATH.
==> ERROR: A failure occurred in prepare().

I think it is running autoconf before installing dependencies. (I am using pacaur by the way)

exdeniz commented on 2020-01-06 22:51

On update 3.2.6+11+g07808097-5 -> 3.2.6+11+g07808097-6 have error:

Switched to a new branch 'makepkg'
==> Starting prepare()...
/home/exdeniz/.cache/yay/gconf/PKGBUILD: line 34: patch: command not found
==> ERROR: A failure occurred in prepare().
    Aborting...
Error making: gconf

UPDATE: [SOLVED] Not installed 'patch' in system.

bpier commented on 2020-01-06 22:17

I get the following error when trying to update using yay:

aclocal: error: couldn't open directory '/usr/local/share/aclocal': No such file or directory

My aclocal is located in /usr/bin/aclocal (owned by automake).

Anything I could do? I couldn’t see any recent changes related to this in either automake or gconf.

Patrick_Hendry commented on 2020-01-06 21:33

@lfercorrea I had the same build error. Installing linuxdoc-tools fixed the problem for me. (I simultaneously installed docbook-xsl-saxon and docbook-xsl-ns, but I doubt they were necessary.)

flying-sheep commented on 2020-01-06 19:20

Most of the packages that “require” it are actually Electron apps that copy&pasted their dependency lists from elsewhere or failed to update them: Chromium (and subsequently Electron) haven’t been dependent on this for years.

If you want to help, you can ask the maintainers of all those apps if they really still need gconf.

None that I use still need it (spotify and hamsket-bin), and their maintainers removed the superfluous dependency.

SebVdk commented on 2020-01-06 15:55

@yan12125: AUR Helper (Pacaur) ignore makedepends variable. Thx

yan12125 commented on 2020-01-06 10:52

@SebVdk: those packages are already listed in makedepends. You may want to check if makepkg on your system is broken.