Package Details: jekyll 3.8.6-3

Git Clone URL: https://aur.archlinux.org/jekyll.git (read-only)
Package Base: jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Keywords: jekyll ruby
Licenses: MIT
Conflicts: ruby-jekyll
Provides: jekyll=3.8.6, ruby-jekyll
Replaces: ruby-jekyll
Submitter: SilverRainZ
Maintainer: SilverRainZ (bjo, bertptrs)
Last Packager: bjo
Votes: 73
Popularity: 1.101432
First Submitted: 2017-11-20 05:56
Last Updated: 2019-08-15 10:55

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 Next › Last »

the-k commented on 2014-06-07 17:34

Please, add nodejs to dependency list.

nickoe commented on 2014-05-18 18:32

OK

veox commented on 2014-05-18 18:28

@nickoe: this will be fixed in the next release: https://github.com/jekyll/jekyll/commit/ceb27fb9a2850e148eac0f02eccc9f6070469036

nickoe commented on 2014-05-17 08:03

I needed to install nodejs, maybe you should add that to the depends array.

nickoe commented on 2014-05-17 07:57

I just installed this package and it depends on a clean system and I get the following error.

$ jekyll --help
/usr/lib/ruby/gems/2.1.0/gems/execjs-2.0.2/lib/execjs/runtimes.rb:51:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
from /usr/lib/ruby/gems/2.1.0/gems/execjs-2.0.2/lib/execjs.rb:5:in `<module:ExecJS>'
from /usr/lib/ruby/gems/2.1.0/gems/execjs-2.0.2/lib/execjs.rb:4:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/jekyll-coffeescript-1.0.0/lib/jekyll-coffeescript.rb:2:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/jekyll-2.0.3/lib/jekyll.rb:73:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/jekyll-2.0.3/bin/jekyll:6:in `<top (required)>'
from /usr/bin/jekyll:23:in `load'
from /usr/bin/jekyll:23:in `<main>'

anatolik commented on 2014-05-14 16:03

> +1 for ruby-celluloid-io.

ruby-listen package misses this dependency. I added a comment on their page. https://aur.archlinux.org/packages/ruby-listen/

I wish everyone use gem2arch to track the gem dependencies. AUR ruby gems were much more usable in this case.

anatolik commented on 2014-05-14 15:49

> Could not find 'parslet' (~> 1.5.0) - did find: [parslet-1.6.0] (Gem::LoadError)

jekyll depends on parslet-1.5 via ruby-toml. Are you sure you have all your dependencies up-to-date?

bchretien commented on 2014-05-13 09:10

+1 for ruby-celluloid-io. I also had a problem with ruby-parslet:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'parslet' (~> 1.5.0) - did find: [parslet-1.6.0] (Gem::LoadError)

alexod commented on 2014-05-09 02:01

anatolik thank you.

I noticed that jekyll also requires ruby-celluloid-io (I do not know whether I requires it directly or via some other dependency) and that execjs requires a javascript runtime (that I reported to that package).

anatolik commented on 2014-05-08 16:14

As a workaround install ruby-timers-1 package