Package Details: kicad-nightly 5.99.0_11121_g5fa5a73c6d-1

Git Clone URL: https://aur.archlinux.org/kicad-nightly.git (read-only, click to copy)
Package Base: kicad-nightly
Description: Electronic schematic and printed circuit board (PCB) design tools
Upstream URL: http://kicad-pcb.org/
Licenses: GPL
Submitter: DX-MON
Maintainer: DX-MON
Last Packager: DX-MON
Votes: 1
Popularity: 0.022807
First Submitted: 2020-10-09 21:32
Last Updated: 2021-06-23 23:00

Pinned Comments

DX-MON commented on 2021-05-16 13:48

Ok, so.. with regards to the 2021-05-16 nightly breakage: if you have updated your system and installed wxPython version 4.1.1-1, please downgrade it for now back to 4.0.7.2-5 as this is the cause of the wxgtk3 3.0.5 vs 3.1.5 breakage.

DX-MON commented on 2020-11-30 13:11

benx45h: There are two major differences between the two packages.

The first is that this one isn't just "whatever the latest is in Git", but rather is pinned to a particular commit each day so as to aid reproducability and try and help guarantee a usable build each update

The second is that kicad-git cannot be installed along side kicad, which means if you want to use both a kicad-git nightly build and stable on the same machine, it's just not possible.. This package on the other hand is designed to be side-by-side installed so suffixes on -nightly and puts both config and binaries in a different location to allow all this to work seamlessly.

Latest Comments

1 2 3 Next › Last »

alfrede commented on 2021-05-16 15:24

After downgrading wxPython to Version 4.0.7.2.5 the Package installs correct. Thanks DX-MON for the quick Response.

DX-MON commented on 2021-05-16 13:48

Ok, so.. with regards to the 2021-05-16 nightly breakage: if you have updated your system and installed wxPython version 4.1.1-1, please downgrade it for now back to 4.0.7.2-5 as this is the cause of the wxgtk3 3.0.5 vs 3.1.5 breakage.

DX-MON commented on 2021-05-16 13:34

Hi @alfrede, thanks for making me aware of this breakage caused by upstream..

With the GL part, it seems my update scripts caught a broken commit on master when the devs were re-jigging some code, so the OGL problems are likely to be gone in tonight's build.

I need to look into what can be done about the wx issue (including asking the devs to stop depending on the just-released version till they can guarantee all distros will have updated their wx packages in time for 6's release), as I don't think it's right to change this to depend on wxgtk3-dev as this will break people's systems (including my own).

Hopefully I can find a satisfactory fix for this in the next few hours.

alfrede commented on 2021-05-16 12:48

When i can´t install the package it comes to the following error: CMake Error at /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find wxWidgets: Found unsuitable version "3.0.5", but required is at least "3.1.5" (found -pthread;;;-lwx_gtk3u_gl-3.0;-lwx_gtk3u_aui-3.0;-lwx_gtk3u_adv-3.0;-lwx_gtk3u_html-3.0;-lwx_gtk3u_core-3.0;-lwx_baseu_net-3.0;-lwx_baseu-3.0;-lwx_gtk3u_propgrid-3.0;-lwx_baseu_xml-3.0;-lwx_gtk3u_stc-3.0)

It looks like the same here: https://aur.archlinux.org/packages/kicad-git/ knapik commented on 2021-04-27 00:54
No longer compiles for me. The nightly builds are now dependent the latest development release of wxWidgets (3.15) and not the stable release. Still, trying to use wxgtk3-dev and wxgtk-common-dev instead of the stable packages, I can't compile to do errors due to a bunch of missing or wrong OpenGL types? I haven't figured out how to get it to compile yet.

warmwaffles commented on 2021-05-03 18:32

@DX-MON thank you for clarifying!

DX-MON commented on 2021-05-03 18:10

@warmwaffles: This was caused because of some faulty packaging of ngspice version 34-1. Downgrading to 33-1 or upgrading to 34-2 fixes this. This package already automatically specifies ngspice as a dep so makepkg -s will do the right thing.

warmwaffles commented on 2021-04-29 19:32

If anyone gets this error

Most of ngspice packages do not provide the required libngspice library.
You can either compile ngspice configured with --with-ngshared parameter
or run a script that does the job for you:
  cd ./scripting/build_tools
  chmod +x get_libngspice_so.sh
  ./get_libngspice_so.sh
  sudo ./get_libngspice_so.sh install

Make sure you install ngspice

DCengineer commented on 2021-01-27 04:17

Minor correction for build options: BUILD_GITHUB_PLUGIN is now deprecated since all KiCad repositories have now been moved to GitLab. It should be removed.

gkeeth commented on 2021-01-26 03:57

Hello again, thanks for adding the rm build/ step!

Another request: is it possible to change -DCMAKE_BUILD_TYPE=Release to -DCMAKE_BUILD_TYPE=RelWithDebInfo?

This would give better debug information for reporting bugs, without the performance penalty of going to full debug builds.

gkeeth commented on 2021-01-17 15:45

Thanks! I will say I was not aware of the -c option to makepkg, so thanks for pointing that out.