Package Details: leela-zero 0.17-1

Git Clone URL: https://aur.archlinux.org/leela-zero.git (read-only, click to copy)
Package Base: leela-zero
Description: Go engine with no human-provided knowledge, modeled after the AlphaGo Zero paper.
Upstream URL: https://github.com/leela-zero/leela-zero
Licenses: GPLv3
Submitter: apetresc
Maintainer: apetresc (algebro)
Last Packager: apetresc
Votes: 5
Popularity: 0.033572
First Submitted: 2018-04-25 03:12
Last Updated: 2019-04-04 19:46

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

apetresc commented on 2019-07-23 15:25

@janwil Hmm, interesting; I'm not sure, as I don't have access to an AMD GPU to test it myself.

One similar problem that is often the culprit - have you upgraded the kernel+headers since your last restart? This sort of thing sometimes occurs in those cases because leela-zero is being compiled against the newly-installed AMD headers, but executing against the old version of the module. If so, just try rebooting and let me know if that helps!

janwil commented on 2019-07-19 18:44

I have AMD RX 480 GPU which seems to be recognised during the test phase with OpenCL support working and everything, but then a test fails:

Started OpenCL SGEMM tuner. Will try 290 valid configurations. /home/janwil/Documents/install/leela-zero/PKGBUILD: line 39: 2209 Segmentation fault (core dumped) ./tests ==> ERROR: A failure occurred in check(). Aborting...

What am I missing?

Thanks in advance, Jan

sfranchi commented on 2019-01-13 16:07

Ah, success at last!

You were right @apetresc, that was the problem. It took me a few iterations of updating kernel/rebooting/reinstalling nvidia-390xx + opencl-nvidia-390xx but it finally passed the test.

I would suggest adding a note to the PKGBUILD recommending users to make sure they have kernel and modules in sync before installing the program

sfranchi commented on 2019-01-13 08:09

@apetresc: Unfortunately that was not the problem, I am getting the same error in the tests phase

Do I have to do anything special to recompile the 390xx driver? I simply rebooted after the updates to the kernel were installed.

apetresc commented on 2019-01-01 19:48

@sfranchi: I've run this PGKBUILD with the nvidia390xx driver before, so I don't think it's that...

The only times I've encountered your error message before, it's always been for the same reason: I'd recompiled my nvidia driver module after upgrading my kernel but before rebooting into that updated kernel. Since the module compiled against the headers of the installed kernel, not the running one, it would fail to load with exactly that error until I rebooted so that the two matched again.

It's a bit of a long shot, but could that be the cause of your issue here?

sfranchi commented on 2019-01-01 18:42

It is actually not---or not only---a permission problem, even though it seems to be part of it. I built leela manually and it does fail to start, with errors related to opencl. It may be a driver issue---my nVidia Quadro 2000 requires the legacy nvdia390xx driver---perhaps it requires some tweaks to get leela/opencl to work with them?

This is the error thrown by $leelaz -w weights.txt

BLAS Core: built-in Eigen 3.3.5 library. Detecting residual layers...v1...256 channels...40 blocks. Initializing OpenCL (autodetecting precision). OpenCL: clGetPlatformIDs terminate called after throwing an instance of 'cl::Error' what(): clGetPlatformIDs Aborted (core dumped)

sfranchi commented on 2018-12-31 17:32

Building fails on my system at the test stage, when no cli platforms are found even though I have an nVidia Quadro 2000 installed, which supports opencl 1.1.

I wonder if there is a permission issue, since running clinfo as a user gives "Number of platforms 0" while running it as super user finds the card/driver and so on.

apetresc commented on 2018-12-04 20:38

@flovo - yup. Did some testing with algebro and this new version should work equally well on NVidia as well as AMD hardware!

CPU-only version is still in the works, though.

flovo commented on 2018-11-29 10:25

Hi, thank you for maintaining this package.

Can you please change the dependency opencl-nvidia -> opencl-driver?

mortimer_mcmire commented on 2018-11-06 15:47

Is there any reason why this depends on libopenblas instead of the [extra] openblas package?