Package Details: lib32-amdgpu-pro-oglp 23.40_1741713-1

Git Clone URL: (read-only, click to copy)
Package Base: amdgpu-pro-installer
Description: AMDGPU Pro OpenGL driver (32-bit)
Upstream URL:
Licenses: custom: AMDGPU-PRO EULA
Groups: Radeon_Software_for_Linux
Provides: lib32-libgl
Submitter: LEW21
Maintainer: Ashark (mesmer)
Last Packager: mesmer
Votes: 123
Popularity: 1.01
First Submitted: 2016-03-28 22:44 (UTC)
Last Updated: 2024-03-28 21:56 (UTC)

Dependencies (1)

Required by (66)

Sources (18)

Pinned Comments

mesmer commented on 2022-12-23 04:31 (UTC) (edited on 2023-05-28 19:28 (UTC) by mesmer)


this package is our try to put amdgpu in ARCH, but this could break or have problems as amd update and change their packages for ubuntu

if anything happens you can always download a older tag in and get the PKGBUILD there, and use makepkg with that build while we update or try to fix :)


Ashark commented on 2019-12-09 20:52 (UTC) (edited on 2022-12-06 08:45 (UTC) by Ashark)

PKGBUILD generator is located here:

AMDGPU PRO wiki page:

New versions will appear here:

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 .. 57 Next › Last »

cschlote commented on 2024-01-19 12:47 (UTC) (edited on 2024-01-19 12:48 (UTC) by cschlote)

For some weeks now, I see the following error in amf-test-linux:

system VCN FW Encode interface version=1.12, expected version=1.13

As proposed I tried older version of the amdgpu packages. Then I see:

system VCN FW Encode interface version=1.12, expected version=1.11

I tried any old version from the last year. The is no version which expects 1.12. It directly jumps from 1.11 to 1.13

And yes, I use the latest linux-firmware-git package.

Can somebody please explain, why there is no matching userland code for the amdgpu fimware for R7700XT, which is installed on my system (on up-to-date Manjaro)?

mesmer commented on 2024-01-09 05:45 (UTC)

its hard to say, when amd fell thats is ok to launch haha, but i expect everything break again, but 5.7.3 is on i think, ill try update tomorrow

OzzyHelix commented on 2024-01-09 00:01 (UTC)

do we know when 23.40 will be released? I'm kind of excited for the improves that promises

mesmer commented on 2023-12-12 21:09 (UTC) (edited on 2023-12-12 21:11 (UTC) by mesmer)

great news, 5.7.2 (aka 23.30) works with linux-firmware in archlinux (dont known about the git version)

the response of amf-test in my 6700 xtx

0123-11-12 18:07:57 46D50740 [AMFEncoderCoreBaseImpl] Warning: Failed to QueryThroughput()!
0123-11-12 18:07:57 46D50740 [AMFEncoderCoreBaseImpl] Warning: Failed to QueryThroughput()!
0123-11-12 18:07:57 46D50740 [EncodeCore]   Error: ./sources/drivers/enc_core/cmn/av1config.cpp(237):Av1Config::IsEncodeSupported(): Unknown Hardware!
0123-11-12 18:07:57 46D50740 [AMFEncoderCoreAv1] Warning:  AMFEncoderCoreAv1Impl::CreateEncodeService() not supported VCN instance 0! 
0123-11-12 18:07:57 46D50740 [AMFEncoderCoreAv1]   Error: ../../../../../runtime/src/components/EncoderCore/EncoderCoreAv1Impl.cpp(343):AMF_ERROR 10 : AMF_NOT_SUPPORTED: Failed to create encode service!
0123-11-12 18:07:57 46D50740 [AMFEncoderCoreAv1] Warning: CreateServices failed.
0123-11-12 18:07:57 46D50740 [AMFEncoderCoreAv1] Warning: *****Failed to create AV1 encoder component.


AMF Encoders

AVC (H264)    = True
HEVC (H265)   = True
AV1           = False

my firmware

❯ yay -Qs linux-firmware
local/linux-firmware 20231211.f2e52a1c-1
    Firmware files for Linux

thx @healing_hand to notify about new release

as always if anyone see a new release fell free to put a issue or pr in the github for the package

Lulzagna commented on 2023-11-22 00:38 (UTC) (edited on 2023-11-22 20:47 (UTC) by Lulzagna)

For obs-amf, rolling back my linux-firmware to version 20230804.7be2766d-2 works for me - I still have the old ZST file on my system that I installed.

I don't know why but my error message said the version was 1.21 and expected 1.20 even though my system is completely up to date except for the firmware.

Edit: Uploaded here in case anyone wanted it. Install with sudo pacman -U <.zst file> and make sure to sudo mkinitcpio -P

EnSER commented on 2023-11-14 10:24 (UTC)

Comments from AMD for latest VCN firmware on linux-firmware: update VCN 4.0.X firmware from 5.7 branch I didn't have any luck with current 5.7 and 5.7.1, but maybe somebody else could try?

mesmer commented on 2023-11-13 22:02 (UTC) (edited on 2023-11-13 22:02 (UTC) by mesmer)

@firastom great work, this package is a nightmare to control and make work, as the firmware is always a problem, and we dont have a way of controlling that without breaking the firmware packages :(

from time to time the amd create a update and or change the version completly, or replace a package , remove a package or just use a version of firmware that i cannot put to work with the arch at all

please fell free to open a branch and a PR int he git so we can try to get a solution for this, but to be fair i am getting tired of controlling the caos of AMD haha

i thought of creating a linux-firmware for amd itself, but it seems to be so much trouble for that driver alone

firastom commented on 2023-11-12 00:09 (UTC)

please read this massage till the end. note: i only care about getting obs-amf working on my machine and i'm not a developer.

man this driver must be synced with certain firmware component but i can't figure it out,any way you have to find that part and make sure to merge it into this package,

when i first installed this firmware i got this error: Error: ./sources/drivers/enc_core/cmn/vcn3commandpacker.cpp(96):system VCN FW Encode interface version=1.29, expected version=1.27

so i blived that the driver is bleeding edge and rolled back to the tag you mentioned below v22.10.15... and the i got this error:

Error: ./sources/drivers/enc_core/cmn/vcn3commandpacker.cpp(96):system VCN FW Encode interface version=1.29, expected version=1.26

so i realized the newer driver is the one in the linux firmware so i went to the archlinux-amdgpu-pro git repo and found out theres newer versions of this driver (5.7.1) , i followed the instructions and built that certain version and installed it. even though i still got the error:

Error: ./sources/drivers/enc_core/cmn/vcn3commandpacker.cpp(96):system VCN FW Encode interface version=1.29, expected version=1.28

at least i'm more closer :) but still the linux firmware is more up to date and you must find the certain parts of the linux-firmware that requires certain version of the software and make sure you put those files on with the package, i know that the package manager can't replace existing packages but i figured one way around it is by downloading the original linux-firmware package modifying it then reinstalling it(don't forget to regenerate kernel) , i hope you can solve this issue , any solution of controling versions independently won't last for too long until it breaks so its really important to consider downloading the firmware version thats already installed and modify it and maybe you can uninstall the original and rename the package you modify so the linux-firmware won't be updated without an update for this package.