Package Details: liblinphone-git 4.5.0.alpha.r112.g868bee338-1

Git Clone URL: https://aur.archlinux.org/liblinphone-git.git (read-only, click to copy)
Package Base: liblinphone-git
Description: A Voice-over-IP phone library and CLI
Upstream URL: http://www.linphone.org
Licenses: GPL
Conflicts: liblinphone
Provides: liblinphone=4.5.0.alpha.r112.g868bee338
Submitter: thrasibule
Maintainer: thrasibule
Last Packager: thrasibule
Votes: 14
Popularity: 0.000178
First Submitted: 2020-09-10 02:09
Last Updated: 2020-09-10 02:09

Latest Comments

1 2 3 4 5 Next › Last »

thrasibule commented on 2020-09-08 01:27

@DAC324, these are just warnings, that's not the case of the error. You probably need to rebuild belle-sip-git and mediastreamer-git.

DAC324 commented on 2020-09-07 12:18

Build fails with:

In file, invoked by /var/tmp/pamac-build-gerd/linphone-git/src/linphone/include/linphone/core.h:65,
                 von /var/tmp/pamac-build-gerd/linphone-git/src/linphone/coreapi/account_creator.c:21:
/var/tmp/pamac-build-gerd/linphone-git/src/linphone/include/linphone/xmlrpc.h:267:64: note: declared here
  267 | LINPHONE_PUBLIC LINPHONE_DEPRECATED LinphoneXmlRpcRequestCbs * linphone_xml_rpc_request_get_callbacks(const LinphoneXmlRpcRequest request);
      |                                                                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
make[2]:  [coreapi/CMakeFiles/linphone-coreapi.dir/build.make:82: coreapi/CMakeFiles/linphone-coreapi.dir/account_creator.c.o] Error 1
make[1]: ** [CMakeFiles/Makefile2:395: coreapi/CMakeFiles/linphone-coreapi.dir/all] Error 2
make:  [Makefile:149: all] Error 2

Manifest0 commented on 2020-04-18 14:32

Figure it out. I had belle-sip installed instead of belle-sip-git. After i installed belle-sip-git, i was able to build linphone-git :-)

Manifest0 commented on 2020-04-17 09:53

Unfortunately this isn't compiling :-(

Am i missing something?

/data/tmp/linphone-git/src/linphone/include/linphone/proxy_config.h:416:42: note: declared here
  416 | LINPHONE_PUBLIC LINPHONE_DEPRECATED void linphone_proxy_config_destroy(LinphoneProxyConfig *cfg);
      |                                          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [coreapi/CMakeFiles/linphone-coreapi.dir/build.make:83: coreapi/CMakeFiles/linphone-coreapi.dir/account_creator.c.o] Erro 1
make[1]: *** [CMakeFiles/Makefile2:411: coreapi/CMakeFiles/linphone-coreapi.dir/all] Erro 2
make: *** [Makefile:150: all] Erro 2
==> ERRO: Uma falha ocorreu em build().
    A cancelar...
:: Unable to build linphone-git - makepkg exited with code: 4

thrasibule commented on 2020-03-28 13:32

same thing with mediastreamer-git... I'll bump the dependencies in the PKGBUILD.

CircleCode commented on 2020-03-28 13:13

you need to install ortp-git

It's indeed better with this one (maybe then you should upgrade the ortp dependency to >=4.4?)

I am now facing a new error:

src/conference/session/tone-manager.cpp:608:41: error: 'MS_SND_CARD_STREAM_DTMF' was not declared in this scope; did you mean 'MS_SND_CARD_STREAM_RING'?
  608 |   ms_snd_card_set_stream_type(ringcard, MS_SND_CARD_STREAM_DTMF);
      |                                         ^~~~~~~~~~~~~~~~~~~~~~~
      |                                         MS_SND_CARD_STREAM_RING
make[2]: *** [src/CMakeFiles/linphone.dir/build.make:899: src/CMakeFiles/linphone.dir/conference/session/tone-manager.cpp.o] Error 1

thrasibule commented on 2020-03-28 01:52

you need to install ortp-git

CircleCode commented on 2020-03-27 19:23

build fails with following errors:

src/linphone/src/conference/session/ms2-streams.h:94:2: error: 'RtpBundle' does not name a type
   94 |  RtpBundle *createOrGetRtpBundle(const SalStreamDescription *sd);
      |  ^~~~~~~~~
src/linphone/src/conference/session/ms2-streams.h:110:2: error: 'RtpBundle' does not name a type
  110 |  RtpBundle *mRtpBundle = nullptr;
      |  ^~~~~~~~~
make[2]: *** [coreapi/CMakeFiles/linphone-coreapi.dir/build.make:184: coreapi/CMakeFiles/linphone-coreapi.dir/callbacks.c.o] Error 1

I do not know if I can report it upstream because I do not find where the build process you're using is documented.

PedroHLC commented on 2020-03-21 20:01

From a clean chroot I got:

CMake Error at cmake/Tools.cmake:31 (message):
  'six' python module not found

Add python-six as a dependency.

But anyway it failed in the building...

thrasibule commented on 2020-01-21 01:29

@ellypsis. Looked like you filed the wrong repo (should be linphone, not linphone-desktop). Anyway, upstream is not very responsive to bug reports so I doubt you'll get an answer. I think the bug is caused by the new version of doxygen. I get the same error as you with doxygen-1.8.17, but it compiles fine with doxygen-1.8.16