Package Details: liblxqt-git 0.10.0.19.g7df67a2-1

Git Clone URL: https://aur.archlinux.org/liblxqt-git.git (read-only)
Package Base: liblxqt-git
Description: Common base library for LXQt components.
Upstream URL: http://lxqt.org
Licenses: GPL2
Conflicts: liblxqt
Provides: liblxqt
Submitter: jleclanche
Maintainer: jleclanche
Last Packager: jleclanche
Votes: 47
Popularity: 0.023171
First Submitted: 2013-10-24 00:54
Last Updated: 2016-04-06 18:14

Latest Comments

Necopinus commented on 2015-09-12 02:38

@c-korn: I ran into this error two. Upgrading libqtxdg-git first resolved it.

c-korn commented on 2015-08-10 15:29

Octopi wants to upgrade the package somehow, but the build fails.
In file included from /tmp/yaourt-tmp-korn/aur-liblxqt-git/src/liblxqt/lxqtplugininfo.cpp:29:0:
/tmp/yaourt-tmp-korn/aur-liblxqt-git/src/liblxqt/lxqtplugininfo.h:40:26: schwerwiegender Fehler: XdgDesktopFile: File or directory not found.

flamusdiu commented on 2015-01-29 12:49

@jleclanche: I guess the build file is wrong. I get this (same as what AbaddonOrmuz gets):

==> Starting build()...
-- The C compiler identification is GNU 4.9.2
-- The CXX compiler identification is GNU 4.9.2
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:136 (find_package):
By not providing "FindKF5WindowSystem.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"KF5WindowSystem", but CMake did not find one.

Could not find a package configuration file provided by "KF5WindowSystem"
with any of the following names:

KF5WindowSystemConfig.cmake
kf5windowsystem-config.cmake

Add the installation prefix of "KF5WindowSystem" to CMAKE_PREFIX_PATH or
set "KF5WindowSystem_DIR" to a directory containing one of the above files.
If "KF5WindowSystem" provides a separate development package or SDK, be
sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/home/pacman/pkg/liblxqt-git4589/liblxqt-git/src/build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().
Aborting...
aura >>= Well, building `liblxqt-git` failed.
aura >>= Would you like to continue anyway? [Y/n] n
aura >>= Building failed.

AlfredoRamos commented on 2015-01-16 21:13

I can see in the CMakeLists.txt

find_package(KF5WindowSystem REQUIRED QUIET)

- https://github.com/lxde/liblxqt/blob/master/CMakeLists.txt#L136

jleclanche commented on 2015-01-16 21:01

liblxqt does not depend on kwindowsystem.

AlfredoRamos commented on 2015-01-16 20:41

It can't be compiled without kwindowsystem.

jleclanche commented on 2015-01-10 18:12

No. https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

johnnybash commented on 2015-01-10 18:11

you should add gcc as build dependencie

dshizzle commented on 2015-01-09 11:47

In order to fix this error the cmake line in the PKGBUILD has to be changed to:
'cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib "$srcdir/$_pkgname"'

argymeg commented on 2015-01-08 17:27

I am trying to rebuild a previously working lxqt installation after a Qt upgrade (to Qt 5.4.0) but I am getting this error during installation:
error: failed to commit transaction (conflicting files)
liblxqt-git: /usr/lib64 exists in filesystem
Errors occurred, no packages were upgraded.

All comments