Package Details: libpanel-git r597.907b820-1

Git Clone URL: https://aur.archlinux.org/libpanel-git.git (read-only, click to copy)
Package Base: libpanel-git
Description: A dock/panel library for GTK 4
Upstream URL: https://gitlab.gnome.org/chergert/libpanel
Licenses: GPL3
Conflicts: libpanel
Provides: libpanel
Submitter: greyltc
Maintainer: greyltc
Last Packager: greyltc
Votes: 1
Popularity: 0.000005
First Submitted: 2021-05-31 11:03 (UTC)
Last Updated: 2022-11-03 20:08 (UTC)

Latest Comments

lfom commented on 2023-05-01 22:30 (UTC) (edited on 2023-05-01 22:31 (UTC) by lfom)

Hello, there! Thanks for maintaining the package. I was using it as a dependency for Pods. Everything was OK up to r723.578c16a-1, but when I tried to update it to r726.063922b-1 the installation gave an error that it could not replace libpanel.so which is owned by ncurses package. I renamed the file temporary and I could install the new version, but then Pods did not find libpanel-1.so.1. I do not know what change in the source (or why it changed), but probably something is wrong since replacing a file from ncurses does not look right. Regards.

0xmrtt commented on 2022-09-10 14:08 (UTC)

Add gi-docgen in deps

Build-time dependency gi-docgen found: NO (tried pkgconfig and cmake)
Looking for a fallback subproject for the dependency gi-docgen

libpanel/docs/meson.build:2:2: ERROR: Automatic wrap-based subproject downloading is disabled

A full log can be found at /home/user/.cache/yay/libpanel-git/src/build/meson-logs/meson-log.txt
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: libpanel-git

euclio commented on 2022-06-29 21:40 (UTC)

Build is failing with

Program vapigen found: NO

libpanel/src/meson.build:181:4: ERROR: Program 'vapigen' not found or not executable

A full log can be found at /home/euclio/.local/share/aur/libpanel-git/src/build/meson-logs/meson-log.txt

Either vala needs to be added as a dependency or the build should configure with -Dvapi=false.

alexteee commented on 2022-04-24 13:21 (UTC)

the libadwaita-git dependency should be libadwaita

euclio commented on 2021-11-15 02:57 (UTC)

This is missing a dependency on libadwaita.