Package Details: libqtxdg-git 3.3.0.3.g7f32cc7-1

Git Clone URL: https://aur.archlinux.org/libqtxdg-git.git (read-only, click to copy)
Package Base: libqtxdg-git
Description: Library providing freedesktop.org specs implementations for Qt.
Upstream URL: https://lxqt.org
Licenses: LGPL2.1
Conflicts: libqtxdg, libqtxdg-qt5-git
Provides: libqtxdg=3.3.0.3.g7f32cc7
Replaces: libqtxdg-qt5-git
Submitter: jleclanche
Maintainer: jleclanche (yan12125)
Last Packager: yan12125_2
Votes: 40
Popularity: 0.000000
First Submitted: 2013-10-24 00:26
Last Updated: 2019-02-19 04:53

Latest Comments

1 2 3 4 Next › Last »

yan12125 commented on 2020-04-28 19:10

@petef4: either removing -git or switch all lxqt packages to -git is fine. Just don't mix stable and -git packages.

Some facts that might help you on decision:

  • -git packages are frequently updated, and stable ones are updated once in a few months
  • New features and not-critical bug fixes are available in -git packages only

petef4 commented on 2020-04-28 09:55

I installed this and liblxqt-git a few weeks back as some of the dependencies for qps-git. With the release of LXQt 0.15 I now see a conflict in pacman between libqtxdg and libqtxdg-git. It seems to me that the official release has skipped ahead of -git. Please advise if I should remove my -git packages or switch my remaining official packages to their -git counterparts.

stefonarch commented on 2016-09-18 08:24

After installing this package all the others LXQt components fail compiling with:

CMake Error at /usr/share/cmake/qt5xdg/qt5xdg-targets.cmake:76 (message):
The imported target "Qt5Xdg" references the file

"/usr/lib64/libQt5Xdg.so.1.3.0"


Manually compiling directly from git solves.

yan12125 commented on 2016-08-03 17:03

Got the same problem here. Need qt5-svg

pmattern commented on 2016-08-02 14:29

qt5-svg has to be added to makedepends, see https://github.com/lxde/libqtxdg/pull/100.

pmattern commented on 2015-04-21 14:06

Upstream dropped support of Qt 4. As a consequence switch USE_QT5 isn't supported any longer either.

dshizzle commented on 2015-01-09 11:42

I found a way to fix this error. Just change the line in the PKGBUILD where cmake gets executed to:
"cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_QT5=true .."

dshizzle commented on 2015-01-09 11:41

I found a way to fix this error. Just change the line in the PKGBUILD where cmake gets executed to:
> cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DUSE_QT5=true ..

dizzib commented on 2015-01-06 12:31

@dshizzle yes I'm seeing exactly that error

dshizzle commented on 2015-01-04 11:59

Is anyone else getting the error
> libqtxdg-git: /usr/lib64 exists in filesystem
on install?

The compiled package contains some files located in /usr/lib64 but I think it should be changed to /usr/lib because lib64 is just a symlink.