Package Details: libretro-mgba-git r5835.a9e96c7d-1

Git Clone URL: https://aur.archlinux.org/libretro-mgba-git.git (read-only)
Package Base: libretro-mgba-git
Description: A Nintendo Gameboy Advance Emulator - Libretro Core
Upstream URL: https://mgba.io/
Licenses: custom:MPL2
Conflicts: libretro-mgba
Provides: libretro-mgba
Submitter: Vaporeon
Maintainer: Vaporeon
Last Packager: Vaporeon
Votes: 13
Popularity: 0.122990
First Submitted: 2015-03-13 01:15
Last Updated: 2019-06-18 05:55

Required by (3)

Sources (1)

Latest Comments

1 2 Next › Last »

oi_wtf commented on 2019-05-31 14:05

I get a compiler error when building:

In file included from /build/libretro-mgba-git/src/mgba/src/gba/core.c:22:
/build/libretro-mgba-git/src/mgba/include/mgba/internal/gba/renderers/gl.h:32:10: fatal error: GLES3/gl3.h: No such file or directory
 #include <GLES3/gl3.h>
          ^~~~~~~~~~~~~
compilation terminated.
make[2]: *** [CMakeFiles/mgba.dir/build.make:661: CMakeFiles/mgba.dir/src/gba/core.c.o] Error 1
Seems like this package should (make)depend on mesa:
% pacman -Fs gl3.h    
extra/mesa 19.0.5-1 usr/include/GLES3/gl3.h ...

cecton commented on 2018-07-03 12:32

(I mean I even ran a game on it and it works)

cecton commented on 2018-07-03 12:31

I just tried to compile on armv7h for the Pi 2 and it works fine. I think you can add it to the list of supported architecture.

agapito commented on 2017-12-26 14:02

error: file owned by 'libretro-core-info' and 'libretro-mgba-git': 'usr/share/libretro/info/mgba_libretro.info'

Bkacjios commented on 2017-12-25 16:04

The mgba_libretro.info conflicts with the package libretro-core-info. You should really add libretro-core-info to the makedepend list and let it provide mgba_libretro.info, otherwise you can get package conflicts like this..

file owned by 'libretro-core-info' and 'libretro-mgba-git': 'usr/share/libretro/info/mgba_libretro.info'

Vaporeon commented on 2017-01-11 00:16

are you sure?

produnis commented on 2017-01-03 06:55

since last update, it says it cannot verify integrity...

ProfessorKaos64 commented on 2016-09-15 14:28

Can you please ad "groups=('libretro')" (sans quotes) so this shows up when installing the "libretro" group package set?

swiftscythe commented on 2016-07-21 08:47

Hi! Would you mind adding these two lines to the PKGBUILD so that it can also been used with gnome-games?

mkdir -p "$pkgdir"/usr/lib/retro-1.0/plugins
ln -s /usr/lib/libretro/mgba_libretro.so "$pkgdir"/usr/lib/retro-1.0/plugins/libretro-game-boy-advance.so

Thank you!

nicodemus commented on 2016-03-30 12:54

This crashes retroarch. Can you look into this please?