Package Details: libva-intel-driver-g45-h264 1:2.3.0-1

Git Clone URL: https://aur.archlinux.org/libva-intel-driver-g45-h264.git (read-only)
Package Base: libva-intel-driver-g45-h264
Description: Video Acceleration (VA) API for Linux
Upstream URL: https://01.org/linuxmedia/vaapi
Licenses: MIT
Conflicts: intel-gpu-tools, libva-intel-driver
Provides: libva-intel-driver
Replaces: libva-intel-driver
Submitter: pedromj
Maintainer: pedromj (alium)
Last Packager: alium
Votes: 59
Popularity: 0.061010
First Submitted: 2014-08-04 02:05
Last Updated: 2018-12-28 10:50

Required by (21)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

Raziel23 commented on 2017-10-17 09:10

I think it's time to move to a newer hardware. Nevertheless thank you @alium for maintaing this package for so long.

hans0 commented on 2017-09-29 17:59

What a pity :(

hans0 commented on 2017-06-02 18:39

@alium: Works for me, too! Great work, keep it up! Thanks :)

Raziel23 commented on 2017-05-31 19:09

@alium: For me it works. Thanks for updating the package.

hans0 commented on 2017-04-25 21:01

@Raziel23 works like charm :)
@alium Thank you very much : )

hans0 commented on 2017-04-25 19:49

@Raziel23 I didn't know that, so I will try mpv-git plus patch.

Raziel23 commented on 2017-04-25 19:17

@hans0: I can't reproduce your issue when playing 1080p h264 video on mpv-git. bomi-git base on mpv player, but it contains mpv source code in its tree that wasn't update for nearly 2 years, see here:
https://github.com/xylosper/bomi/tree/master/src

So basically you use 2 years old mpv player that may contains some old bugs. So I can't speak about such old version. Furthermore bomi project is not develop anymore:
https://github.com/xylosper/bomi/issues/490

For me it works without stutters when playing 1080p h264 video on mpv-git plus this driver with patch from @tegularius.

hans0 commented on 2017-04-25 15:14

I tried this driver with bomi-git: 720p acceleration works, 1080p stutters (without the patch from @tegularius).

Raziel23 commented on 2017-04-22 15:45

@tegularius: Yes your patch works without patching mpv or ffmpeg.

@alium: Please apply the patch from @tegularius.

tegularius commented on 2017-04-22 13:44

Parts of the driver had not been patched for support h264.
It seems that the driver support for ironlake is the same as it should be for g4x-devices, so I patched it to return the same surface-attribute-information.
Works as far as I can tell.

https://gist.github.com/anonymous/e5383bd3c78bf389d124fcecde5a1556