Package Details: logitechmediaserver 7.9.2.arch2-1

Git Clone URL: https://aur.archlinux.org/logitechmediaserver.git (read-only)
Package Base: logitechmediaserver
Description: Slimserver for Logitech Squeezebox players. This server is also called Logitech Media Server. (Release-Version, if you prefer bleeding edge consider using logitechmediaserver-git instead)
Upstream URL: https://github.com/stefansielaff/slimserver
Keywords: logitech slimserver squeezebox
Licenses: GPL, custom
Submitter: vesath
Maintainer: stef.an
Last Packager: stef.an
Votes: 67
Popularity: 0.450345
First Submitted: 2011-11-03 06:54
Last Updated: 2018-08-07 10:19

Latest Comments

1 2 3 4 5 6 ... Next › Last »

mnd999 commented on 2018-09-16 09:52

On ARM I get:

cp: will not overwrite just-created '/home/mark/logitechmediaserver/pkg/logitechmediaserver/opt/logitechmediaserver/CPAN/perllocal.pod' with 'CPAN/build/5.28/lib/perl5/armv7l-linux-thread-multi/perllocal.pod'
==> ERROR: A failure occurred in package().
    Aborting...

Solved, the clean doesn't work properly. I had to manually delete /home/mark/logitechmediaserver/src/slimserver-vendor-7.9.2.arch2/CPAN/build/5.26

stef.an commented on 2018-08-07 10:30

I've updated to the latest GIT-Version and removed the upper limit for perl for now. Perl upgrades didn't break much since Perl 5.22 to 5.24 so I hope this makes upgrading a little easier for everyone.

The dependency perl-net-upnp is removed, I've returned to the LMS-packed version. The package has to be rebuilt after upgrading perl of course... Hope it works for you :)

Renophaston commented on 2018-08-06 19:49

I can confirm that upgrading perl doesn't seem to break anything on my machine (x86_64), and I'll comment again if I find anything broken.

For what it's worth, I never uninstalled this package: I edited the LMS PKGBUILD, built+installed it, then upgraded perl... and then rebuilt+installed LMS again just in case.

setone commented on 2018-08-06 18:55

With LMS installed, perl will not upgrade to the latest (version 5.28), because LMS requires version 5.26.

I worked around this by doing the following:

  1. uninstall LMS (after backing up /opt/logitechmediaserver/prefs)
  2. do the normal pacman/yaourt/pacaur update, which will replace perl v5.26 with v5.28.
  3. edit PKGBUILD to reflect the perl version requirement
  4. build LMS, install, restore prefs

It seems to work fine.

t.langlois commented on 2018-03-26 08:19

Thanks, oalexander & stef.an.

Yesterday I could install perl-net-upnp ignoring the architecture (makepkg -Acsi). Then I could install logitechmediaserver.

I just tested running the server and it works !

I had to follow thomassh's advice and install polkit (pacman -S polkit).

stef.an commented on 2018-03-26 08:01

It looks like perl-net-upnp has been removed from the official repos and the aur package doesn't have the arm flag. Currently you can either manually install perl-net-upnp by adding arch=armv7h or remove the dependency from this package if you don't use upnp. I'll try to find a solution apsap.

oalexander commented on 2018-03-25 19:23

I believe that perl-net-upnp is in AUR as well. You will have to install it first before logitechmediaserver

t.langlois commented on 2018-03-24 21:48

Did someone installed this package on ARM ? While trying to install the perl-net-upnp package (dependency) I get the error:

$ makepkg -si ==> ERROR: perl-net-upnp is not available for the 'armv7h' architecture.

==> ERROR: An unknown error has occurred. Exiting...

Is there any way to solve this ?

My hardware is a Wandboard Quad.

thomassh commented on 2018-01-28 12:38

I just decided to update the rather old arch installation on my media server, which I rarely dare doing as updating e.g. LMS usually isn't completely painless and this time is no exception, however it wasn't too bad :-)

So just to let you know, it sems that you are lacking a dependency on "polkit" and maybe the "json-c" version. The detailed story goes like this:

After upgrading to LMS 7.9.1, which also turned out to depend on an AUR build of perl-net-upnp) it failed to start due to an error "bla. bla. freedesktop bla. bla. Polkit1" - unfortunately the exact error message has left my console history. However, after some googling I decided to do a "pacman -S polkit" and that did the trick.

Alas, I was not there yet. The logitechmediaserver service now failed to start due to the error:

slimserver.pl[458]: The following modules failed to load: EV JSON::XS

Frustrating at first, as I thought that my system was completely up to date at this point, however that turned out not to be true, so "pacman -Syu" made everything work like a charm. I think that this indicates that you also are missing a dependency on a "JSON thingy" in the package - it may be "json-c" version but I'm not completely sure.

ispotter commented on 2017-10-09 17:37

Have built and installed arch3 on x64 and can still scan as expected. Have never used LMS for anything other than audio so that's fine by me for now.

Thanks for the work on this guys.

Ian