Package Details: logitechmediaserver 7.9.1.arch1-1

Git Clone URL: (read-only)
Package Base: logitechmediaserver
Description: Slimserver for Logitech Squeezebox players. This server is also called Logitech Media Server. (Release-Version, if you prefer bleeding edge consider using logitechmediaserver-git instead)
Upstream URL:
Keywords: logitech slimserver squeezebox
Licenses: GPL, custom
Submitter: vesath
Last Packager:
Votes: 66
Popularity: 2.500652
First Submitted: 2011-11-03 06:54
Last Updated: 2017-06-09 19:59

Dependencies (16)

Required by (0)

Sources (3)

Latest Comments

madsepperl commented on 2017-06-26 17:19


many thanks for this hint ! uninstall. upgrade and then re-install did the trick. I was not aware of that procedure, thanks for the heads-up !

madsepperl commented on 2017-06-25 14:54

Hi madsepperl,
this is not caused by 7.9.1, this version is already prepared for perl 5.26

This is the usual way to handle lms on perl upgrades:
- uninstall lms (this leaves your libraray and data intact)
- upgrade system
- rebuilt and install lms

If you're using yaourt, it might handle that for you but I'm not sure about that (yaourt -Syu instead of pacman -Syu).

madsepperl commented on 2017-06-25 14:31

since 7.9.1 is available, I get the following message on trying to upgrade:

"error: failed to prepare transaction (could not satisfy dependencies)
:: logitechmediaserver: installing perl (5.26.0-1) breaks dependency 'perl<5.25'"

Is there anything I can do ? Or just wait for an upgrade ?
Thanks !!

Gregoire commented on 2017-06-09 21:20

Sorry for my comment yesterday : I needed to recompil all perl modules I got from aur and now it works perfectly !!!
Thanks again for all.

setone commented on 2017-06-08 19:24

I've diagnosed what happened to me (see a couple of posts down). Here are the steps I took:

1. As a sanity check, installed on an x86_64 machine with lots of memory and everything worked as expected.
2. Uninstalled from the armv6h machine and reinstalled, using 'yaourt -S logitechmediaserver'. I noticed somewhere near the end of the build that there was a failure to write to /tmp (because it was 100% full). The build/install process carried on as if nothing was wrong, and zipped up a package and installed it. Trying to start the server gave me the same results as I reported below.
3. I saved the /opt/logitechmediaserver directory off to the side, then uninstalled again, and this time downloaded a snapshot using 'yaourt -G logitechmediaserver' and built locally using 'makepkg -s'.
4. After installing the result of that, everything was in good shape. I did a diff of the "good" logitechmediaserver directory with the "bad" one and noticed many discrepancies. I could report them but I don't think it's all that relevant - the main point is that some users will run out of space in /tmp if they install the way I did in step 2, and end up with a bad install. If there's a solution to this problem it would probably be to fail the build when the write error occurs, instead of packaging up the parts that didn't fail and installing the result.

As always, thank you for all the excellent work.

Gregoire commented on 2017-06-08 18:22

Thanks for the update.
Any idea on how to solve this :[28669]: XS.c: loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080)

Thanks again.

auberginepop commented on 2017-06-08 13:59

I second happyarchlinuser - Thank you!

jewelux commented on 2017-06-08 13:46 Not so important, but the correct version number is 7.9.1.

happyarchlinuser commented on 2017-06-08 02:58

Thanks for maintaining this package up to date!

setone commented on 2017-06-07 22:04

I'm having some issues with the new version running on armv6h. I cleaned out everything - uninstalled the previous LMS, made sure that /opt/logitechmediaserver was gone, etc. Perl was updated today to v5.26.

The result of trying to start the service is: The following modules failed to load: DBI XML::Parser::Expat JSON::XS YAML::XS Sub::Name

I've tried installing the repo versions of all the modules that LMS complained about:

pacman -S perl-dbi perl-xml-parser perl-json-xs perl-yaml-libyaml perl-sub-name

and then after trying to start the service, I see:

The following CPAN modules were found but cannot work with Logitech Media Server:
Audio::Scan (loaded <not found>, need 0.93)
Image::Scale (loaded 0.08 but missing object file, need 0.08)
XML::Parser: and versions don't match at /opt/logitechmediaserver/CPAN/XML/ line 20.
BEGIN failed--compilation aborted at /opt/logitechmediaserver/CPAN/XML/ line 22.
Compilation failed in require at (eval 137) line 1.
BEGIN failed--compilation aborted at (eval 137) line 1.

Running with the d_startup parameter gives much more verbose output:

All comments