Package Details: lxqt-panel-git 0.13.0.1104.gc6f910fd-1

Git Clone URL: https://aur.archlinux.org/lxqt-panel-git.git (read-only)
Package Base: lxqt-panel-git
Description: The LXQt desktop panel
Upstream URL: https://github.com/lxde/lxqt-panel
Licenses: GPL2
Conflicts: lxqt-panel
Provides: lxqt-panel
Submitter: jleclanche
Maintainer: pmattern
Last Packager: pmattern
Votes: 46
Popularity: 0.000022
First Submitted: 2013-10-24 01:13
Last Updated: 2018-12-15 22:21

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

yan12125 commented on 2016-09-05 15:11

Hello pmattern would you like to maintain this package? I'm not quite familiar with LxQT internals and feel an LxQT maintainer is also better as a package maintainer.

pmattern commented on 2016-09-05 12:59

Would you please re-enable plugin-sysstat?
Basically there has never been any real reason to disable the plugin, see discussion below.

yan12125 commented on 2016-08-08 05:50

Adapted and updated. Now it builds fine.

yan12125 commented on 2016-07-31 09:11

Requires libdbusmenu-qt5 to build.

jwhickman commented on 2016-07-22 01:20

This has been failing to build for me, apparently since after the 433343e commit. Looking throught the comments, I checked liblxqt, and realized that pkgbuilder was not seeing it as a dependency. After manually installing it, problem resolved. Does this need added as a dependency here, or somewhere?
This was the error I was getting:
=========================================================================
/home/jwh/Build/pkgbuilder/lxqt-panel-git/src/lxqt-panel/plugin-taskbar/lxqttaskbar.cpp: In member function ‘void LXQtTaskBar::buttonMove(LXQtTaskGroup*, LXQtTaskGroup*, const QPoint&)’:
/home/jwh/Build/pkgbuilder/lxqt-panel-git/src/lxqt-panel/plugin-taskbar/lxqttaskbar.cpp:232:25: error: ‘class LXQt::GridLayout’ has no member named ‘animatedMoveInProgress’
|| mLayout->animatedMoveInProgress()
^~~~~~~~~~~~~~~~~~~~~~
make[2]: *** [plugin-taskbar/CMakeFiles/taskbar.dir/build.make:68: plugin-taskbar/CMakeFiles/taskbar.dir/lxqttaskbar.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1231: plugin-taskbar/CMakeFiles/taskbar.dir/all] Error 2

goetzc commented on 2016-04-07 01:57

@pmattern Thanks!

pmattern commented on 2016-04-06 12:08

Absolutely agree plugin-sysstat should be enabled again.
A discussion about eventually abandoning libsysstat was started (https://github.com/lxde/lxqt/issues/704) but a decision hasn't been made yet and both libsysstat and plugin-sysstat are still subject to some development for now.
So it would really be desirable to have the plugin at hand in order to test which is one of the main purposes of VCS packages after all.

Also confirming the need to add libdbusmenu-qt5 as runtime dependency.

.SRCINFO hasn't been updated quite a while.

@goetzc
The build failure you're posting could very well be due to an outdated version of liblxqt, see https://github.com/lxde/liblxqt/commit/825771a.

goetzc commented on 2016-04-03 23:16

I get a build error:

lxqtmainmenu.cpp:413:86: error: ‘LXQT_GRAPHICS_DIR’ was not declared in this scope
mButton.setIcon(QIcon{settings()->value(QLatin1String("icon"), QLatin1String(LXQT_GRAPHICS_DIR"/helix.svg")).toString()})

goetzc commented on 2016-04-03 23:09

What is libdbusmenu-qt5 used for?

CDF-H commented on 2015-10-03 19:03

You need to add libdbusmenu-qt5 to the depends.