Package Details: networkmanager-qt-git r678.cf2d3da-1

Git Clone URL: https://aur.archlinux.org/networkmanager-qt-git.git (read-only)
Package Base: networkmanager-qt-git
Description: Qt-only wrapper for NetworkManager DBus API
Upstream URL: https://projects.kde.org/projects/extragear/libs/libnm-qt
Licenses: LGPL
Conflicts: libnm-qt-git, libnm-qt5, networkmanager-qt
Provides: libnm-qt5, networkmanager-qt
Replaces: libnm-qt-git
Submitter: arojas
Maintainer: Dimtree
Last Packager: Dimtree
Votes: 26
Popularity: 0.005020
First Submitted: 2015-01-01 23:23
Last Updated: 2016-10-13 23:17

Required by (8)

Sources (1)

Latest Comments

tajidinabd commented on 2015-01-02 18:22

when trying to build this package i get the following error

CMake Error at CMakeLists.txt:5 (find_package):
Could not find a configuration file for package "ECM" that is compatible
with requested version "1.6.0".

The following configuration files were considered but not accepted:

/usr/share/ECM/cmake/ECMConfig.cmake, version: 1.5.0


i can see from a kde commit

http://commits.kde.org/frameworkintegration/e3bfaaa7bc9532ab8ec2a6ed2f7307a3cb2bc128

the change
any workaround for this error

arojas commented on 2015-01-01 23:26

Merging in networkmanager-qt-git

tajidinabd commented on 2014-12-30 20:33

Please update PKGBUILD to reflect name change

tajidinabd commented on 2014-12-30 19:03

do you have a package build to reflect the new name for this package

sl1pkn07 commented on 2014-12-26 11:54

libnm-qt is gone, now named networkmanager-qt

https://projects.kde.org/projects/frameworks/networkmanager-qt

greetings

bhushan commented on 2014-12-26 11:53

This was renamed to networkmanager-qt

arojas commented on 2014-03-13 19:50

This should be changed to point to the NM/0.9.8 branch, master is now qt5 based

Siosm commented on 2014-01-02 17:35

I've updated this package to keep it closer to the non-git version but it does not build for me right now. I'm orphaning it as I don't use it anymore.

foxcm2000 commented on 2011-11-26 16:56

I get a strange build error through yaourt. 'libmm-qt-git' is listed as a required dependency and I have that package installed. However, when I go to build libnm-qt-git, it always fails with a "libmm-qt" package not found error. The libmm-qt package is not listed in the build file.. is this dependency getting checked out of the GIT repository and incorrectly causing the build to fail? There is no libmm-qt package in either the main repositories or on AUR.