Package Details: networkmanager-ssh-git r233.fe3dc5d-1

Git Clone URL: https://aur.archlinux.org/networkmanager-ssh-git.git (read-only, click to copy)
Package Base: networkmanager-ssh-git
Description: SSH VPN support for NetworkManager
Upstream URL: https://github.com/danfruehauf/NetworkManager-ssh
Keywords: manager network networkmanager ssh vpn
Licenses: GPL2
Provides: networkmanager-ssh
Submitter: lyoko
Maintainer: monotykamary
Last Packager: monotykamary
Votes: 15
Popularity: 0.000044
First Submitted: 2016-09-17 13:57 (UTC)
Last Updated: 2018-01-15 15:30 (UTC)

Latest Comments

1 2 Next › Last »

Mysak0CZ commented on 2021-12-21 11:44 (UTC)

libnm-glib has been deprecated and removed from base repos. Could you please update this package to depend on libnm instead?

Harvie commented on 2019-03-02 16:03 (UTC)

Missing dependency: sshpass

Morganamilo commented on 2019-01-30 12:50 (UTC)

Please use git+https not just git. This lets people download the sources on networks where the git protocol is blocked.

striges1111 commented on 2018-01-19 20:57 (UTC)

Thanks @monotykamary. It actually works good. I guess you may need adjust your iptables on the server side.

monotykamary commented on 2018-01-15 15:41 (UTC)

I have remodelled the PKGBUILD to include flags from the original Fedora .spec file with the addition of forcing the flag "--enable-more-warnings=no". It builds fine on my end; but if it doesn't run well on your machine and/or you have and would like to add some input to the PKGBUILD, feel free to comment.

carlos commented on 2018-01-15 12:00 (UTC) (edited on 2018-01-15 12:00 (UTC) by carlos)

Deprecation upstream bug: https://github.com/danfruehauf/NetworkManager-ssh/issues/74

drws commented on 2018-01-01 00:42 (UTC)

Build is failing because of multiple errors: ‘NMTCQdisc’ is deprecated: Not available before 1.10.2 [-Werror=deprecated-declarations]

brozowski commented on 2017-09-04 13:57 (UTC)

Missing depends : nm-connection-editor intltool

Reylak commented on 2017-01-12 10:02 (UTC)

I needed to install intltool in order to compile this package. Otherwise I got something similar to this (with different line number and version): ./configure: line 2743: syntax error near unexpected token `0.41.0' ./configure: line 2743: `IT_PROG_INTLTOOL(0.41.0)'

lyoko commented on 2016-12-27 12:26 (UTC)

I'll check it and fix it! thank you.