Package Details: ossia-score 3.2.0-1

Git Clone URL: https://aur.archlinux.org/ossia-score.git (read-only, click to copy)
Package Base: ossia-score
Description: ossia score, an interactive sequencer for the intermedia arts
Upstream URL: https://ossia.io
Licenses: GPLv3
Conflicts: ossia-score-git
Provides: ossia-score
Replaces: i-score
Submitter: jcelerier
Maintainer: jcelerier
Last Packager: jcelerier
Votes: 10
Popularity: 0.074944
First Submitted: 2018-04-26 22:11 (UTC)
Last Updated: 2024-05-28 13:55 (UTC)

Latest Comments

1 2 3 4 Next › Last »

begin-theadventu commented on 2023-07-12 17:50 (UTC)

Thanks.

jcelerier commented on 2023-07-12 15:07 (UTC)

fixed, except for clang which is a depends (as score uses libclang for JIT-compilation features)

begin-theadventu commented on 2023-07-12 08:04 (UTC) (edited on 2023-07-12 08:28 (UTC) by begin-theadventu)

Shouldn't boost, clang and lld be in makedepends? And qt6-quickcontrols2 removed.

Also, ysfx-git provides ysfx, so I think it would make sense to write it without the -git suffix.

jcelerier commented on 2022-08-23 12:41 (UTC)

hi @tomas_vtipil, can you try 3.1.1 ? I just tested and it builds fine here

tomas_vtipil commented on 2022-07-11 21:05 (UTC) (edited on 2022-07-11 21:07 (UTC) by tomas_vtipil)

hi, trying to build, cannot get past this:

[ 44%] Building CXX object src/plugins/score-plugin-avnd/CMakeFiles/score_plugin_avnd.dir/cmake_pch.hxx.gch
In file included from /home/tomas/builds/ossia-score/src/build/src/plugins/score-plugin-avnd/CMakeFiles/score_plugin_avnd.dir/cmake_pch.hxx:12,
                 from <command-line>:
/home/tomas/builds/ossia-score/src/src/plugins/score-plugin-avnd/Crousti/Layer.hpp: In member function ‘QGraphicsItem* oscr::LayoutBuilder<Info>::createCustom(T&)’:
/home/tomas/builds/ossia-score/src/src/plugins/score-plugin-avnd/Crousti/Layer.hpp:64:52: error: expected ‘;’ before ‘{’ token
   64 |       if constexpr(requires { typename T::item_type{}; }) {
      |                                                    ^
/home/tomas/builds/ossia-score/src/src/plugins/score-plugin-avnd/Crousti/Layer.hpp: In member function ‘auto oscr::LayerFactory<Info>::makeItemImpl(oscr::ProcessModel<Info>&, QGraphicsItem*) const’:
/home/tomas/builds/ossia-score/src/src/plugins/score-plugin-avnd/Crousti/Layer.hpp:234:51: error: expected ‘;’ before ‘{’ token
  234 |     if constexpr(requires { typename Info::ui::bus{}; }) {
      |                                                   ^
make[2]: *** [src/plugins/score-plugin-avnd/CMakeFiles/score_plugin_avnd.dir/build.make:77: src/plugins/score-plugin-avnd/CMakeFiles/score_plugin_avnd.dir/cmake_pch.hxx.gch] Error 1
make[1]: *** [CMakeFiles/Makefile2:2817: src/plugins/score-plugin-avnd/CMakeFiles/score_plugin_avnd.dir/all] Error 2
make: *** [Makefile:146: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

dvzrv commented on 2021-11-20 11:56 (UTC)

@jcelerier: Yes, it's not required at runtime, but the pkgconfig integration specifies it as required. I guess it's the more "expected" or "sane" solution to add it as dependency for those three packages.

dvzrv commented on 2021-11-20 11:44 (UTC)

I have now added lv2 to depends for sratom, lilv and suil.

jcelerier commented on 2021-11-20 11:21 (UTC)

@dvzrv I don't think it's an oversight as the lv2 package only provides development-related headers & tooling, I don't think it's needed at any point for e.g. an actual LV2 plug-in to run (but I could be mistaken)

dvzrv commented on 2021-11-20 11:06 (UTC)

Hm, I guess that is an oversight on my part. It appears lv2 should be in depends for sratom, lilv and suil (but currently it is only in makedepends).

jcelerier commented on 2021-11-20 10:10 (UTC)

Thanks @s-ol, interestingly this happens when one has Lilv and Suil but not the LV2 package, I thought the formers would depend on the latter but apparently not.