Package Details: osu-lazer-git 2022.605.1-1

Git Clone URL: https://aur.archlinux.org/osu-lazer-git.git (read-only, click to copy)
Package Base: osu-lazer-git
Description: An open source, free-to-win rhythm game
Upstream URL: https://github.com/ppy/osu
Keywords: game lazer osu peppy ppy rhythm
Licenses: MIT
Conflicts: osu-lazer
Provides: osu-lazer
Submitter: ammonaur
Maintainer: huupoke12
Last Packager: huupoke12
Votes: 41
Popularity: 0.41
First Submitted: 2017-03-25 04:24 (UTC)
Last Updated: 2022-06-05 10:10 (UTC)

Pinned Comments

huupoke12 commented on 2020-08-09 03:20 (UTC) (edited on 2020-10-15 13:56 (UTC) by huupoke12)

Please aware that this package is not supported by the osu! development team and may lose some online functionalities because of the binaries differences with the official builds (see this GitHub issue for more details). Please use the official builds if you want those functionalities.

Latest Comments

1 2 3 4 5 6 .. 13 Next › Last »

AtticFinder65536 commented on 2022-04-08 02:42 (UTC) (edited on 2022-04-08 02:54 (UTC) by AtticFinder65536)

Should the ffmpeg depedency be changed to ffmpeg4.4? While osu!lazer uses whatever the system's ffmpeg is, videos still don't work and there are random crashes when using ffmpeg (5.0). However, if this change was made, osu!lazer would still use ffmpeg 5.0 because it searches for /usr/lib/libavcodec.so etc. which are symlinks to the ffmpeg 5.0 libraries. I run osu!lazer in a container, so I just binded the ffmpeg 4.4 libraries to the generic /usr/lib/libavcodec.so etc. files to override the symlinks for that sandbox, but I wonder if there's a more elegant way to handle something like this.

Edit: After writing this, I just remembered that setting the LD_LIBRARY_PATH is probably a better option. Now instead of binding each ffmpeg 4.4 library to the generic symlink I just run osu!lazer with LD_LIBRARY_PATH set to /usr/lib/ffmpeg4.4:"${LD_LIBRARY_PATH}" to make osu!lazer use the ffmpeg 4.4 libraries. I'm still open to hearing other options.

ppy commented on 2022-01-28 16:11 (UTC)

We will not be targeting dotnet 6 for a while more. The dependencies should be pinned to 5.

NaAlOH4 commented on 2022-01-28 04:25 (UTC)

It was not possible to find any compatible framework version
The framework 'Microsoft.NETCore.App', version '5.0.0' (x64) was not found.
  - The following frameworks were found:
      6.0.0 at [/usr/share/dotnet/shared/Microsoft.NETCore.App]

It seems like ppy is using dotnet 5 and the package will install dotnet 6?

catlover2 commented on 2021-10-31 07:29 (UTC)

@huupoke12 yes, I have installed ca-certificates version 20210603-1

huupoke12 commented on 2021-10-31 07:26 (UTC)

@catlover2 Do you have ca-certificates installed?

catlover2 commented on 2021-10-31 03:59 (UTC)

I'm getting the errors about

error NU3028: Package 'System.Security.Cryptography.Cng 5.0.0' from source '
https://api.nuget.org/v3/index.json': The author primary signature's timestamp found a chain building issue: UntrustedRoot: self signed certificate in certific
ate chain

again. I have dotnet-runtime 5.0.8.sdk205-1 installed, well past version 5.0.5 mentioned below.

huupoke12 commented on 2021-08-07 04:06 (UTC) (edited on 2021-08-07 04:09 (UTC) by huupoke12)

@puyo This is a VCS package, meaning that the pkgver variable shouldn't be used as-is, but to be updated by the pkgver() function in the PKGBUILD. You should report this problem to the aurutils developers instead.

puyo commented on 2021-08-07 01:54 (UTC)

my aur helper aurutils doesn't want to update this unless i specifically tell it to rebuild since line 10 pkgver='2021.416.0.r73.e227c076e5' and the version the package actually has (from line 30's pkgver() i think?) is newer than 2021.416.0

❯ aur sync osu-lazer-git
==> Using [custom] repository
    osu-lazer-git: 2021.804.0.r58.a9c99f149a-1 is newer than 2021.416.0.r73.e227c076e5-1
    there is nothing to do

huupoke12 commented on 2021-04-07 11:01 (UTC) (edited on 2021-04-07 11:11 (UTC) by huupoke12)

@prokoprandacek It's an upstream issue that will be resolved by the release of .NET 5.0.5. See this article for more information.

prokoprandacek commented on 2021-03-26 12:30 (UTC)

I'm getting errors about self signed certificate in certificate chain and expired signature validity period.

log